If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Font prefs do not list cursive and fantasy fonts

VERIFIED DUPLICATE of bug 28899

Status

SeaMonkey
Preferences
P3
normal
VERIFIED DUPLICATE of bug 28899
18 years ago
13 years ago

People

(Reporter: Pierre Saslawsky, Assigned: don)

Tracking

Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
This bug is extracted from bug 28127.

The font prefs doesn't allow you to select the font for the 'cursive' and 
'fantasy' families defined in CSS.

Comment 1

18 years ago
I have some ideas for the font prefs UI. I'm thinking of splitting it into 2,
one that is extremely simple and has a button labelled "Advanced", which takes
you to the other panel or dialog that has all of the hard-core user features,
including cursive and fantasy. How does this sound so far? Juraj, if you don't
mind, I'd like to own this bug. Would you reassign it to me if you agree?
h'm, an Advanced button that opens another dialog could be nifty...! german,
your thoughts?
(Reporter)

Comment 3

18 years ago
I usually don't like the idea. We end up with interfaces like many applications 
on Windows that show modal dialogs on top of modal dialogs. It usually 
demonstrates a lack of ingenuity in the design. Note that we may already have to 
make a separate modal dialog just for the screen resolution (bug 5599). It would 
be confusing to stick in there unrelated things and equally bad to have another 
modal dialog for something else. We have plenty enough space in the font prefs, 
let's use it first.

Comment 4

18 years ago
add matt to the cc list.
Erik, I also think that separating the font prefs into two categories might be 
better than trying to make everybody happy with the current design... I'm 
quite curious to see how the UI will look like in Beta 2 :-)
Assignee: jbetak → erik

Comment 6

18 years ago
What about a dialogue that came up like this:

+------------------------------------------------------------------+
|   [ Variable Width Font ^]                                       |
|	[ Western (ISO-8859-1) ^]                                    |
|                                                                  |
|        Face:                        Size:                        |
|        +--------------------+       [ 10 pt. ]                   |
|        |Technical          ^|                                    |
|        |Tempus Sans ITC    #|       Style:                       |
|        |Times New Roman    #|       +----------------------+     |
|        |>Trebuchet MS<     $|       |Bold                 ^|     |
|        |Tw Cen MT          #|       |Italic               $|     |
|        |TypoUpright        ^|       |>Roman<              ^|     |
|        +--------------------+       +----------------------+     |
|                                                                  |
|   [ ] Always use the fonts I have chosen, overriding document-   |
|        specific fonts.                                           |
| ---------------------------------------------------------------- |
|   Display Web pages using [ Windows (96 dpi) ^] logical          |
|    resolution.                                                   |
...

Dropdowns:

 [ Variable Width Font ^] [ Windows (96 dpi)  ^]
 | Fixed Width Font     | | Macintosh (?? dpi) |
 | --                   | | Custom...          |
 | CSS 'serif'          | +--------------------+
 | CSS 'sans-serif'     |
 | CSS 'monospace'      |
 | CSS 'cursive'        |
 | CSS 'fantasy'        |
 | --                   |
 | Font Substitutions   |
 +----------------------+

This has excellent simplicity for the novice -- they bring it up,
it lets them change their default variable width font, and they 
don't even have to know the other choices exist. But it also gives
power users control, and it's extensible as new CSS definitions or
other reasons for additional font options arise (plugins?).

Comment 7

18 years ago
I responded to the above in the mozilla.ui newsgroup. Let's continue the
discussion there.
(Reporter)

Comment 8

18 years ago
jbetak & erik: we can separate the font prefs in two or more categories. We can 
even take advantage of that new design to throw in some new features like "don't 
ever show me a font smaller than this" (see bug 30910) or - why not? - some 
attributes remapping such as "show blink as bold" or "show italic as cursive". 
All I'm saying is that we should avoid UIs based on separate modal dialogs.
(Reporter)

Comment 9

18 years ago
*** Bug 581 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: M16

Comment 10

18 years ago
This bug was originally opened to address cursive and fantasy. Recent discussion
on mozilla.ui suggests that we have enough of a consensus that these should not
be added to the UI. So I'm marking this bug WONTFIX.

A couple of unrelated ideas were mentioned in this bug report, such as BLINK.
If anybody wants to pursue those ideas, please open separate bug reports. Do
NOT reopen this one, which is reserved for the "cursive/fantasy in UI" issue.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WONTFIX
Are there at least hidden prefs for these things that can be used by CSS purists
by editing prefs.js?
(Reporter)

Comment 12

18 years ago
Erik- I guess we did not read the same messages on the newsgroup because I 
reached the exact opposite conclusion which is:
1) We are going to put these settings.
2) They won't be hidden in a popup.

Reopened.
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 13

18 years ago
I suggest - leaning towards request - that the Netscape folks have a meeting in 
person before either closing this bug or make a final decision concerning the UI. 
We already had plenty of feedback from the newsgroup, it's time to get things 
moving. Let's do a final draft, submit for an ultimate feedback, ignore the 
responses and implement that thing. Sounds good?

Comment 14

18 years ago
Both Todd and I agree that cursive and fantasy should not be in the UI. Do you
disagree? If so, please speak up in the newsgroup. Thanks!

Comment 15

18 years ago
David, you can see the names of the various prefs here:

  http://lxr.mozilla.org/seamonkey/source/modules/libpref/src/win/winpref.js
(Reporter)

Comment 16

18 years ago
Hey everybody, when I wrote "Let's do a final draft, submit for an ultimate 
feedback, ignore the responses and implement that thing", those who know me will 
have recognized my usual sarcastic style. And the other ones, I don't care.

Updated

18 years ago
Status: REOPENED → ASSIGNED
Target Milestone: M16 → M15

Updated

18 years ago
Target Milestone: M15 → M16

Comment 17

18 years ago
Pierre, I'm not going to add cursive and fantasy to the font prefs UI. If you
still want to have them added, you may wish to contact ben@netscape.com, who
touched the font prefs most recently.
Assignee: erik → pierre
Status: ASSIGNED → NEW
(Reporter)

Comment 18

18 years ago
Reassigned to Ben. Marked beta2.
Assignee: pierre → ben
Keywords: nsbeta2

Updated

18 years ago
Target Milestone: M16 → M17

Comment 19

18 years ago
*** Bug 28899 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 28883
*** Bug 28899 has been marked as a duplicate of this bug. ***
(Reporter)

Updated

18 years ago
Blocks: 28899
(Assignee)

Comment 21

18 years ago
Re-assigning this to me so it won't be re-opened to Ben.
Assignee: ben → don
Target Milestone: M17 → ---
(Assignee)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 22

18 years ago
Well, if bug #28899 is not a duplicate of this bug, then this bug must me a
duplicate of 28899.  Let's not have two of these floating around.

Do NOT re-open this bug without consulting me first.  Or I will promptly mark it
WONTFIX.


*** This bug has been marked as a duplicate of 28899 ***
(Reporter)

Comment 23

18 years ago
I subscribe to it.  Having opened the bug, I'm verifying it dup of the more 
general one.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.