Wrong Details in Auto-update from beta2 to RC1

RESOLVED WONTFIX

Status

()

Toolkit
Application Update
--
minor
RESOLVED WONTFIX
12 years ago
9 years ago

People

(Reporter: didaio, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

1. In auto-update window "Details" link go to beta1 page.
2. In auto-update window new version is 1.5 but not 1.5 RC1


Reproducible: Always

Steps to Reproduce:
1. Help - Check updates

Comment 1

12 years ago
The same things here, but also after running auto-update and restarting, auto-update ran again, this time downloading a 6MB update file and restarting again, and the help > about and window header still show "version 1.5 Beta 2" and "Mozilla Firefox Beta 2" respectively.  I'm not sure what else needs to be done, but if doing what the prompts say doesn't work, something's wrong.
Scott, you're talking about bug 314684.
Confirming incorrect details link.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

12 years ago
We don't intend to fix this.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
*** Bug 314777 has been marked as a duplicate of this bug. ***

Comment 6

12 years ago
You dont intend to fix this?? Does that mean its simply a problem with beta releases? If a full version 1.5 was released would it correctly identify it as the newest version and update accordingly??

Comment 7

12 years ago
Yes, this is simply an issue that RC1 *is* 1.5 (it's a real release candidate, which means that if no significant regressions were found we could release it as 1.5).
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.