SVG Font Size Printing Error

RESOLVED FIXED

Status

()

Core
SVG
RESOLVED FIXED
12 years ago
11 years ago

People

(Reporter: bug, Assigned: Robert Longson)

Tracking

({fixed1.8.1, regression})

Trunk
x86
Windows XP
fixed1.8.1, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Hi,
While printing out the basic calendar in the above URL 
( http://www.thors-hammer.net/temp/calendar.svg ), 
in Firefox 1.5 Beta 2 and Firefox 1.5 RC 1, the font size does not print correctly, it prints out much larger than the coding states, regardless of Portrait or Landscape printing.  This issue also occurs in all other SVG documents that I have checked with text.  Furthermore, the SVG graphics print out correctly on all files.  All of the tested files render perfectly on-screen, it is only the printing that has an issue.

This issue does not occur with Firefox 1.5 Beta 1, the document prints correctly.

Thank you for any assistance that you may be able to provide.

Reproducible: Always

Steps to Reproduce:
1.Open the URL in Firefox 1.5b2 or 1.5RC1 ( http://www.thors-hammer.net/temp/calendar.svg )
2.Print the file.
3.Error occurs in printed font size.

Actual Results:  
Font size prints much larger than the encoded  ...font-size="18">  I do not have the facilities to measure what the acutal print out size is, but it is clearly incorrect.  Printer is an HP DeskJet920c, which works perfectly, and is using the current printer drivers.

Expected Results:  
In Firefox 1.5b1, the error was not reproduceable.  The font size printed perfectly.

This issue occured on multiple profiles, and also on the nightly (01Nov05) build for Firefox Deerpark Beta 2 1.6a1.  This issue was not reproduceable on the nightly Mozilla build, because Mozilla does not support SVG at this time.

Comment 1

12 years ago
I see this as well with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051101 Firefox/1.6a1.
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: General → SVG
Ever confirmed: true
Keywords: regression
Product: Firefox → Core
QA Contact: general → ian
Summary: SVG Font Size Printing Error (only in 1.5 RC 1 and 1.5 Beta 2... works in 1.5 Beta 1) → SVG Font Size Printing Error
Version: unspecified → Trunk
(Reporter)

Comment 2

12 years ago
This issue persists with the latest Firefox 1.5RC2 install.
User Agent: 
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5
(Reporter)

Comment 3

12 years ago
This issue continues with the latest Firefox 1.5rc3 build.
User Agent:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Comment 4

12 years ago
This issue continues in the final version of Firefox 1.5

Comment 5

12 years ago
I have this problem as well with the latest Firefox 1.5RC3.
I'am using Windows 2000, and my printer is a Samsung ML-1450 laser printer.
The printed text is about 3-4 times bigger than expected, and the text is printed with low resolution. The pixels can be seen very clearly.

Not sure if this is related, but thinn black lines do not print very well either. It looks like they are printed as low resolution raster graphics.
For example, I use SVG to draw family trees: http://www.brolinembedded.se/misc/erlandsson.svg
The black lines are printed as relatively wide dithered light grey lines. Not very pretty.

Comment 6

12 years ago
I can reproduce this issue with Firefox 1.5, using a LaserJet 2300 printer with HP's PCL 6 driver.

Comment 7

12 years ago
I'm cuirous to know is there any changes concerning this topic.
This bug seems to be much more important because it renders the SVG almost inusable for text printing.
(Reporter)

Comment 8

12 years ago
This issue persists in the new Firefox 1.5.0.1
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Comment 9

12 years ago
*** Bug 325887 has been marked as a duplicate of this bug. ***

Comment 10

12 years ago
*** Bug 322161 has been marked as a duplicate of this bug. ***

Comment 11

12 years ago
Not sure whether to create a new bug. I have two SVG-related issues (one is related/same as this bug, the other is different) and can reproduce on both SeaMonkey 1.0 and Firefox 1.5.

(Applies on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060130 SeaMonkey/1.0))

SVG files not printed in the right place
========================================
When SVG files are printed, either to a physical printer or a virtual one (such as PDF Creator), the SVG file is not printed in the correct place. Usually the SVG file is printed on the next page, in the location that it should have been printed at. Examples:
http://perceptualsolutions.com/misc/graph.html
http://perceptualsolutions.com/misc/rect1.html

Also see http://perceptualsolutions.com/misc/SVGPRINT.PDF for an example of an incorrectly printed document (see http://www.causeway.co.uk/demos/svg/).

Font sizes wrong in printout
============================
The font size is about 10 or 15 times what it should be - for example, in the 'graph' example above, the "Apple" label is almost as high as the circle's radius.

In view of this, would it be possible to have GDI+ enabled builds of SeaMonkey? I can't help but think that the move to Cairo as the SVG rendering backend has been a bit rushed. People can't use the Adobe SVG Plugin either as it crashes both Firefox and SeaMonkey (see https://bugzilla.mozilla.org/show_bug.cgi?id=319299 ). One of the oft-quoted reasons for using Cairo on Win32 is that it relieves the need to download GDI+ - well, I think it's worth downloading it to get better SVG rendering and printing.

The SVG print preview bug also remains: https://bugzilla.mozilla.org/show_bug.cgi?id=322914 .
(Reporter)

Comment 12

11 years ago
This issue persists in both of the following versions:

1.5.0.2 (Firefox)
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

2.0a1 (Bon Echo)
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060321 Firefox/2.0a1
(Reporter)

Comment 13

11 years ago
This issue is still continuing in the latest Firefox 1.5.0.3 build.
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

This ticket has been opened for over 6 months and it is getting rather inconvenient to have to keep a copy of Firefox 1.5 Beta 1 installed to print out business presentations that were created in SVG.  Is this issue going to be resolved? Is anyone working on this? Will I have to escalate it to get some action?
(Reporter)

Comment 14

11 years ago
This issue persists in the newest Firefox 2.0 Beta 1.
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1b1) Gecko/20060707 Firefox/2.0b1

... In addition to still existing within the current primary 1.5 build:
User Agent = Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.4) Gecko/20060508 Firefox/1.5.0.4
(Assignee)

Comment 15

11 years ago
Created attachment 229259 [details] [diff] [review]
possible patch

I have some questions.
a) Does this patch break Linux/Mac printing?
b) When did prints become so small on Windows? Printing the SVG in the URL gives a tiny output on Windows trunk builds rather than the full page output of Firefox 1.5. Is it due to the change to gfx? This issue is clearly a different bug though.
Attachment #229259 - Flags: review?(tor)

Comment 16

11 years ago
Comment on attachment 229259 [details] [diff] [review]
possible patch

OS-X and Linux printing appear unaffected by this patch, and do have text the right size.

mkaply: this would be a good thing to pick up on the branch.

The printing problems with windows on the trunk are likely due to interaction with thebes, which is currently the default.  If you build with --enable-default-toolkit=windows the behavior should be the same as 1.5.
Attachment #229259 - Flags: review?(tor) → review+
(Assignee)

Comment 17

11 years ago
Created attachment 229448 [details] [diff] [review]
branch patch
Assignee: general → longsonr
Status: NEW → ASSIGNED
Attachment #229448 - Flags: review?(tor)
(Assignee)

Updated

11 years ago
Attachment #229259 - Flags: superreview?(roc)

Updated

11 years ago
Attachment #229448 - Flags: review?(tor) → review+
Attachment #229448 - Flags: superreview+
Attachment #229259 - Flags: superreview?(roc) → superreview+
(Assignee)

Comment 18

11 years ago
Checked into trunk.
(Assignee)

Updated

11 years ago
Attachment #229448 - Flags: approval1.8.1?
Comment on attachment 229448 [details] [diff] [review]
branch patch

a=dbaron on behalf of drivers.  Please check in to the MOZILLA_1_8_BRANCH and mark fixed1.8.1 when you have.
Attachment #229448 - Flags: approval1.8.1? → approval1.8.1+
(Assignee)

Comment 20

11 years ago
Checked into MOZILLA_1_8_BRANCH
Status: ASSIGNED → RESOLVED
Last Resolved: 11 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
(Assignee)

Comment 21

11 years ago
*** Bug 357559 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.