Update fails from TB 1.5b2 to TB 1.5rc1

RESOLVED DUPLICATE of bug 314684

Status

Thunderbird
General
--
major
RESOLVED DUPLICATE of bug 314684
12 years ago
12 years ago

People

(Reporter: Tyler Larson, Assigned: Scott MacGregor)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: version 1.5 Beta 2 (20051006)

After following the instructions at http://forums.mozillazine.org/viewtopic.php?t=336429
to allow updating to TB 1.5rc1, the update successfully downloads, but fails to install. Now every time I start TB, I get the "One or more files could not be updated..." dialog; TB remains at version 1.5b2.

Reproducible: Always

Steps to Reproduce:
1. Download the update using TB's "Check for Updates" feature
2. Restart TB as instructed
3. Profit!

Actual Results:  
Update fails to apply

Expected Results:  
1.5rc1 bliss

Here are some of the more interesting lines out of last-update.log.

EXECUTE REMOVE defaults/profile/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}/install.rdf
EXECUTE REMOVE defaults/profile/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd}
copy_file: failed to open or stat: -1,defaults/profile/extensions/{972ce4c6-7e08-4474-a285-3208198ce6fd},13
backup_create failed: 6
### execution failed


failed: 6
calling QuitProgressUI
(Reporter)

Comment 1

12 years ago
Created attachment 201639 [details]
my last-update.log file
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5
(Reporter)

Comment 2

12 years ago
Created attachment 201651 [details]
updates\0\update.log (obsolete)
(Reporter)

Comment 3

12 years ago
Comment on attachment 201651 [details]
updates\0\update.log (obsolete)

updates\0\update.log was caused by a tb instance that wouldn't die. Irrelevant to this bug.
Attachment #201651 - Attachment description: updates\0\update.log (which may be more relevant) → updates\0\update.log (obsolete)
Attachment #201651 - Attachment is obsolete: true

Comment 4

12 years ago
Pretty sure this is a dupe...

*** This bug has been marked as a duplicate of 314684 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.