Closed Bug 31479 Opened 20 years ago Closed 8 years ago

about:demo

Categories

(SeaMonkey :: Help Documentation, enhancement, P3)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: bugzilla, Assigned: neil)

References

Details

(Keywords: helpwanted)

Attachments

(10 files, 1 obsolete file)

what about an about:demo or about:features?
Think advertising - for a 'storefront' - show off all the Mozilla coolness here 
for the few and new who want to see what Mozilla is capable of.
Severity: normal → enhancement
Status: NEW → ASSIGNED
henrik, this is doable but someone needs to write the html/css/js for the page 
that you want to load. Maybe you can excercise mozilla's features and post the 
sources at which point i could hook it up for you.
I think, this is a good idea. <about:feature> could show a summary of "best"
features. <about:feature/-area-> (e.g. <about:feature/mailnews/viewer/html> or
<about:feature/core/chrome/skin>) could list features of a certain area. Until
here, HTML should be sufficient (assuming the protocol handler is hooked up).

Feature "leafs" (feature "primitives") could link to an animated or even
interactive demo. This part is probaly a lot of work.

verah, are you likely to implement at least the first part? If not, can you add
a helpwanted keyword?
OS: Windows 98 → All
Hardware: PC → All
Sorry, I can't do this at present. I could provide a list of features we 
might want to highlight, and some text, if someone else could author this. 

Adding the helpwanted keyword.
Keywords: helpwanted
Target Milestone: --- → Future
Updating QA Contact to elig...welcome back!
qa assigning open/resolved help bugs to paw
QA Contact: elig → paw
spam: mass-moving currently open help bugs to Terri, who now does qa on 'em. :)
QA Contact: paw → tpreston
Hey, I know -- let's include a Quake clone written in XUL.
verah@netscape.com: Can you please upload your list as an attachment 
to the bug. I may be interested in working on this.
Oh good! I'll create the list/descriptions as soon as possible. Probably Tuesday 
12/5. When I've got that I'll reassign to Zach.
cool. I can't do anything too hard, but I can sure try!
Here we go... sorry for the delay; I've been sick as a dog. I'm attaching
documents that sort of outline/describe four "about..." demos that I think would
be good. I'm suggesting the following:

About Mozilla's End User Features (you'd probably want a different title)
About My Sidebar (for developers -- who want to create tabs)
About Themes (for people who want to create themes)
About Standards Support

There may be more possibilities, or better possibilities, but these are the ones
that come to my mind. I've provided some text (and three gifs), but these are
naturally Netscape-centric seeing as how I've been writing Netscape stuff for
the past three years! However, I'm hopeful that the examples will help you write
text appropriate for Mozilla.

You might want to look at the "What's New in Netscape 6" piece, which is a tour
of features. It's not really a demo, in that the reader is not led through a
series of steps and there's nothing animated or anything fancy like that.

Reassigning to Zach. Good luck!
Assignee: verah → zach
Status: ASSIGNED → NEW
Attached file Outline for "About Themes" doc (obsolete) —
accepting bug. The first thing that comes to mind for me is how to animate 
stuff. I was thinking flash, except I don't have flash and flash doesn't come 
with mozilla. I can't export director as shockwave or java applets because 
mozilla doesn't come with shockwave or java by standard. This leaves 
animated gifs. Does anyone have any better ideas?
Status: NEW → ASSIGNED
JavaScript and the DOM? That would demonstrate our cool standard support at the
same time for those who care...
DUH! Time to play with dreamweaver timelines and make them work in 
mozilla.
Faking it using Mozilla keywords!
http://www.mozilla.org/docs/end-user/keywords.html

Create a bookmark as normal to whatever it is you want
Then go to bookmark properties
set the keyword to 
about:demo
or 
about:features 
or 
about:whateveryoulike

Now if you type about:demo in the location bar mozilla will automagically
follow your link.  


There isn't much need to fake it with keywords because we can just hook 
it right into the browser. The problem is getting the demo site. Once we 
have the site ready, hooking it up is no problem. I'm still not sure exactly 
when I plan to have this done, but It's higher on my list than before.
Blocks: 96712
how about bug 170240?
about:feature would be better served by bug 103608
about:demo might be better served by bug 170240
and some of the stuff mentioned could go into Mozilla Help files
Attached image demo: Tabbed Browser
Graphical version of what demo could be
Attached image demo: Theme
how-to-make-a-skin is overkill to be put in the Help files
Attachment #20575 - Attachment is obsolete: true
What you show is more like a tutorial. I thought a demo where something which
doesn't teach, but just shows some cool things. I guess that would stress the
Gecko renderer, then, rather than the UI. Like that 3D cube (lost the URL),
something like netcenter's news boxes, but implemented on the client side and
with tabs, some cool resizable SVG, a webpage how it *should* look like ;) etc..
s/where/were

oh, and if you make a tutorial, instead of showing screenshots, why not mark the
real UI elements with a red (blinking?) flame, like the DOM inspector does?
Attached image demo: Caret Browsing
Ben, you are right. Perhaps all the attachments could go into
about:features (or bug 103608, or bug 170240)?
Product: Browser → Seamonkey
about:abandoned? Or is there work still going on on this?
Assignee: zach → nobody
Status: ASSIGNED → NEW
Assignee: nobody → neil
QA Contact: tpreston → danielwang
Is this really wanted yet? Some features explained in the attachments sample files are not available any longer, others are now common in most browsers...
It's dead Jim. =>WONTFIX.
Status: NEW → RESOLVED
Closed: 8 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.