All users were logged out of Bugzilla on October 13th, 2018

Placement/position of Firefox window is not saved if the window is maximed (stretched) over the entire desktop

VERIFIED INCOMPLETE

Status

()

VERIFIED INCOMPLETE
13 years ago
8 years ago

People

(Reporter: jeroen, Unassigned)

Tracking

unspecified
All
Windows XP
Points:
---
Bug Flags:
blocking-firefox3.6 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Just installed RC1 on OS X 10.4.3.

Everything works fine, except from one thing. If I maximize and let Firefox stretch out over my entire desktop, and then quit Firefox, then restart it again, the position of the Firefox window is not saved. There is a small space at the bottom where I can still see my desktop. This does not happen with Firefox 1.0.7 and previous versions.

Very irritating.

Reproducible: Always

Steps to Reproduce:
1. Open and maximize you Firefox 1.5 RC1 window, then stretch it out over your entire desktop.
2. Quit Firefox
3. Restart Firefox - you will now see an empty space at the bottom of the screen, where I can see my desktop. Thus, Firefox is not complete stretched out over my desktop!

Actual Results:  
Same as under "Details"

Expected Results:  
It should have been maximized over the entire desktop. Just as Firefox 1.0.7 does.

Comment 1

9 years ago
I can reproduce this even with Firefox 3.0.12 on Windows XP Pro SP3.

I'm using an expanded desktop (two monitors, each on an separate graphics controller). Every time I had firefox maximized on the second monitor it will be restored on the first one after restart. However this does not happen if firefox is not maximized. Then the position will be restored correctly on the second monitor.

see also bug #477966
Flags: blocking-firefox3.6?
Component: Shell Integration → General
QA Contact: shell.integration → general
Resolving incomplete, since the original report was about PPC OSX Firefox 1.5, and the confirmation is a different version and platform.

Florian: please file a new bug with steps to reproduce.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: blocking-firefox3.6? → blocking-firefox3.6-
OS: Mac OS X → Windows XP
Hardware: PowerPC → All
Resolution: --- → INCOMPLETE

Updated

8 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.