Closed Bug 314938 Opened 14 years ago Closed 13 years ago

Test run add/modify/delete

Categories

(Webtools Graveyard :: Litmus, defect)

defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: coop, Assigned: coop)

References

()

Details

We need the ability to create and manipulate test runs from test groups/lists. This is the major piece of functionality that is present in Testrunner but still missing from Litmus.

More detail:
http://wiki.mozilla.org/Litmus:Requirements#Replicate_Testrunner_functionality
Depends on: 314928
Assignee: zach → ccooper
Depends on: 323768
QA Contact: ccooper → litmus
Status: NEW → ASSIGNED
The Litmus test run schema has been updated. Here are the new tables (from schema.pl):

$table{test_run_criteria} =
        'test_run_id int(11) not null,
         build_id int(10) unsigned not null,
         platform_id smallint(6) not null default "0",
         opsys_id smallint(6) not null default "0",

         primary key(test_run_id,build_id,platform_id,opsys_id)';

$table{test_run_testgroups} =
        'test_run_id int(11) not null,
         testgroup_id smallint(6) not null,

         primary key(test_run_id,testgroup_id)';

$table{test_runs} =
        'test_run_id int(11) not null primary key auto_increment,
         name varchar(64) not null,
         description varchar(255),
         start_timestamp datetime not null,
         finish_timestamp datetime not null,
         enabled tinyint(1) not null default "1",
         product_id tinyint(4) not null,
         branch_id smallint(6) not null,
         creation_date datetime not null,
         last_updated datetime not null,
         author_id int(11) not null,

         index(name),
         index(description),
         index(start_timestamp),
         index(finish_timestamp),
         index(enabled),
         index(product_id),
         index(branch_id),
         index(creation_date),
         index(last_updated),
         index(author_id)';
*** Bug 337496 has been marked as a duplicate of this bug. ***
Blocks: 370211
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Product: Webtools → Webtools Graveyard
You need to log in before you can comment on or make changes to this bug.