Wrong date chosen when adding entry after 11:30pm

RESOLVED DUPLICATE of bug 283512

Status

Calendar
Internal Components
RESOLVED DUPLICATE of bug 283512
12 years ago
12 years ago

People

(Reporter: Allan McRae, Assigned: shaver)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051103 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20051103 Mozilla Sunbird/0.3a1

When adding an event when the time is after 11:30pm, they day after the one intended is automatically selected in the "from" and "to" parts of the entry dialog. 

A similar problem - based on the same underlying problem - happens when trying to add an "all day" event after 11:00pm. The "to" part of the dialog is the day after the intended making the event last two days.

Reproducible: Always

Steps to Reproduce:
1. Wait until 11:30
2. Try adding an entry on a particular day
3. Look at what day is selected in the entry dialog

Actual Results:  
Event occurs day after intended

Expected Results:  
Event should occur on day intended

Comment 1

12 years ago

*** This bug has been marked as a duplicate of 283512 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.