Closed Bug 315297 Opened 17 years ago Closed 17 years ago

Credits in about dialog don't scroll and fade in correctly

Categories

(Firefox :: General, defect)

defect
Not set
trivial

Tracking

()

RESOLVED FIXED
Firefox 2 alpha1

People

(Reporter: fryn, Assigned: fryn)

References

Details

(Keywords: fixed1.8.1)

Attachments

(1 file, 2 obsolete files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051105 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051105 Firefox/1.5

The credits in the about dialog appear from the middle of the dialog and don't fade in.

Reproducible: Always
add this to userChrome.css to make it display correctly:

#creditsBox {
  height: auto !important;
  bottom: 8px !important;
}
#creditsBox > .title > .motto {
  margin-bottom: 180px !important;
}
is it still possible to get this minor riskless fix for 1.5 ?
not a bug, just a better "rendering" of the credits ..
Flags: blocking1.8rc2?
for both FF and TB
There's no need for height: auto; as auto is default.

I'd recommend requesting review from either mconnor or bryner
Severity: normal → trivial
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 1.5 Branch
Flags: blocking1.8rc2? → blocking1.8rc2-
Flags: blocking1.9a1?
Asa, could you at least get someone to review my patch so it has a chance of being checked in the trunk once Firefox 1.5 is released?
Attachment #202027 - Attachment description: add the userchrom fix to the css → add userchrome fix from comment 1 to css in credits .xhtml
Attachment #202027 - Flags: review?(mconnor)
I'm sure mconnor will get to the review when he gets done with the more important bugs. 
(In reply to comment #3)
> Created an attachment (id=202027) [edit]
> add the userchrom fix to the css
> 
> for both FF and TB
> 

i know i'm being picky, but you added one too many lines of white space in the patch. notice how there are two lines of white space separating the set of brackets in the first half of the patch.

thanks for making the patch. i wasn't sure where to add my fixes.

proud to contribute my share, however small it may be, to the firefox project.
Attached patch Remove un-needed return (obsolete) — Splinter Review
whoops, fixed
Attachment #202027 - Attachment is obsolete: true
Attachment #202156 - Flags: review?
Attachment #202027 - Flags: review?(mconnor)
shayne, are you going to request review from mconner?

no hurry. there's no way this is going to get checked in until Firefox 1.5 is finalized and released, etc.
Comment on attachment 202156 [details] [diff] [review]
Remove un-needed return

opps, thought I did
Attachment #202156 - Flags: review? → review?(mconnor)
Flags: blocking1.8.1?
Version: 1.5 Branch → Trunk
i changed the version to trunk so mconner would more likely review it:

see here:
http://steelgryphon.com/blog/?p=67
I just realized the following:
Firefox 1.5 = Gecko 1.8
Firefox 2.0 = Gecko 1.8.1
Firefox 3.0 = Gecko 1.9

this fix should be checked into both the branch and the trunk.
what should i set the version to?
Version: Trunk → unspecified
Flags: blocking-aviary2?
(In reply to comment #12)
> I just realized the following:
> Firefox 1.5 = Gecko 1.8
> Firefox 2.0 = Gecko 1.8.1
> Firefox 3.0 = Gecko 1.9
> 
> this fix should be checked into both the branch and the trunk.
> what should i set the version to?
> 

yeah a lot of people got confused with this. Months ago, I thought we gonna had Firefox 3 on Gecko v2.0 ;-) You should set this to trunk,anyway it can make 1.8.1 even if you set it to trunk.
Flags: blocking1.8.0.1?
Version: unspecified → Trunk
This patch should make the other attachments obselete.
I have confirmed that "height: auto" is not needed.

Could someone look over this patch and make sure I got the numbers right?

like this thing that you have to add:
@@ -80,26 +80,30 @@
Attachment #205184 - Flags: review?(mconners)
Flags: blocking1.8rc2-
1.8.0.1/ff1.5.1 is for security and stability fixes only.  this would be better in 1.9 and maybe 1.8.1
Flags: blocking1.8.0.1? → blocking1.8.0.1-
Comment on attachment 202156 [details] [diff] [review]
Remove un-needed return

obsoleting in favour of the revision of this patch
Attachment #202156 - Attachment is obsolete: true
Attachment #202156 - Flags: review?(mconnor)
Attachment #205184 - Flags: review?(mconners) → review?(mconnor)
(In reply to comment #16)
> (From update of attachment 202156 [details] [diff] [review] [edit])
> obsoleting in favour of the revision of this patch
> 

i put down the wrong person to ask for a review. i meant to put down you. sorry. could you review this?
Attachment #205184 - Flags: review?(mconnor)
Attachment #205184 - Flags: review+
Attachment #205184 - Flags: approval1.8.1+
Whiteboard: [checkin needed]
Assignee: nobody → studio17
Trunk:
mozilla/browser/base/content/credits.xhtml; new revision: 1.14;
mozilla/mail/base/content/credits.xhtml; new revision: 1.9;
1.8:
mozilla/browser/base/content/credits.xhtml; new revision: 1.10.4.3;
mozilla/mail/base/content/credits.xhtml; new revision: 1.4.2.3;
Status: NEW → RESOLVED
Closed: 17 years ago
Flags: blocking1.9a1?
Flags: blocking-firefox2?
Keywords: fixed1.8.1
Resolution: --- → FIXED
Whiteboard: [checkin needed]
Target Milestone: --- → Firefox 2
Hmm.. this bug is a dublicate of bug 237804.. where to i submitted a patch a long time ago.. close that bug now...
*** Bug 237804 has been marked as a duplicate of this bug. ***
Target Milestone: Firefox 2 → Firefox 2 alpha1
You need to log in before you can comment on or make changes to this bug.