Status

()

Core
CSS Parsing and Computation
--
minor
RESOLVED DUPLICATE of bug 215083
12 years ago
12 years ago

People

(Reporter: Margus Sipria, Assigned: dbaron)

Tracking

1.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fi; rv:1.8) Gecko/20051025 Firefox/1.5

#profemail a {content: 'secret@email.com'}

won't overwite a tag, but if i use :after or :before it will...

Reproducible: Always

Steps to Reproduce:
<a href="mailto:secret@email.com" style="content: 'secret@email.com'">secret@email....</a>
Actual Results:  
secret@email....

Expected Results:  
secret@email.com

a {
 font-size: 0pt !important;
 font-size: 9pt;
}

a:after {
 content: "secret@email.com";
 font-size: 9pt;
}

css that i where using to work around woun't work in opera... and it is bad work around.

Comment 1

12 years ago
True, the content property correctly only applies inside a :before/:after
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Reporter)

Comment 2

12 years ago
http://www.w3.org/TR/css3-content/#inserting3

Applies To: all elements, ::before, ::after, ::alternate, ::marker, ::line-marker, margin areas, and @footnote areas


Does it always have to **** the dot? I creat web pages and i support Firefox, is so bad to do this?
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

Updated

12 years ago
Assignee: nobody → dbaron
Component: General → Style System (CSS)
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.0 Branch
(Assignee)

Comment 3

12 years ago
In CSS2, 'content' only applies to :before and :after.  You seem to be requesting that we implement the CSS3 version, where it applies to all elements, so marking duplicate.  Please don't add comments to the duplicate bug unless they help in fixing that bug.

*** This bug has been marked as a duplicate of 215803 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 4

12 years ago
Er, typo in bug number
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Assignee)

Comment 5

12 years ago

*** This bug has been marked as a duplicate of 215083 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.