Printing multiple pages drops line on page break - Text Cut Off

VERIFIED FIXED in Future

Status

MailNews Core
Printing
P3
normal
VERIFIED FIXED
18 years ago
10 years ago

People

(Reporter: tallison, Assigned: dcone (gone))

Tracking

Trunk
Future
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

18 years ago
I have a two page email (simple text) which, when printed, drops 3 lines of text
from the email message.  It doesn't cut them off (ie: no 1/2 lines), but drops
them entirely from the print job.  These lines are dropped in the form feed
between the two pages.
Printer set up as 0.50 margins on top & bottom each.
Mozilla/M14 - build ID 2000022916
Linux 2.2.14
HP DeskJet 540 Printer
Grayscale, Last page first.
I believe this is related to bug 24405.  If I reprint with all margins set to
0.00 I get Text cut-off on both the left and top/bottom of the page.

Updated

18 years ago
QA Contact: lchiang → fenella

Updated

18 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 1

18 years ago
It would help to have a test case.. Printing multi page documents work for me.. 
So should I create a multi page email.. send it to myself and print if from 
there.. or just open a multi page plain text document.. or ????

Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: --- → M19

Comment 2

18 years ago
there is a similar case in bug 40821 where ONE line gets cut off every page.
URL is http://www.ecst.csuchico.edu/~beej/guide/net/
(Assignee)

Comment 3

18 years ago
This bug has been marked future because we have determined that it is not 
critical for netscape 6.0.  If you feel this is an error, or if it blocks your 
work in some way -- please attach your concern to the bug for reconsideration.
Target Milestone: M19 → Future

Comment 4

18 years ago
We may want to relnote this so the user knows and can print one page at a time.
Keywords: relnote2

Comment 5

18 years ago
I have this problem with 2000-09-08-21/Linux
If I print this page http://www.physik.fu-berlin.de/~fsi/statistik_en.html using
Times Roman (the only font available for print under Unix) and the
marginsettings 0.5 on A4 paper, I miss the following:

The third table is rather large. The last row completely shown is 51.
Kaiserslautern, from "52. Bielefeld" I only see the upper 10% or 15% (i.e. I
only see some black dots).

On the next page (4) it starts with "54. Oldernburg".

I would expect:
(a) that I don't get a partly visible line
(b) that not two lines are not printed

Suggest nsbeta3 since this reduces the value of the printed output.
(This doesn't only happen with tables, but also with some other HTML elements,
though I don't have a example at hand.)

Suggest 4xp since these cut off problems did occure in Netscape 4.x only in a
much less fequency.

(I can provide you with an print-out example in PS/PDF if needed be.)

Updated

18 years ago
Keywords: relnote2 → relnote3, relnoteRTM
(Assignee)

Comment 6

17 years ago
*** Bug 55129 has been marked as a duplicate of this bug. ***
lchiang: Can you confirm your workaround fixes the problem? If it doesn't, 
there's no point relnoting it...

The blurb:
It seems unclear to me whether this bug requires either of a "developer" or 
"user" release note for Netscape 6 RTM. If anyone feels it does, can they please 
draft one and then nominate with the relnote-user or relnote-devel strings in 
the Status Whiteboard.

Thanks :-)

Gerv
Keywords: relnote3

Comment 8

17 years ago
Assign it to Sheelar
QA Contact: fenella → sheelar

Comment 9

17 years ago
reassign to esther
QA Contact: sheelar → esther
(Assignee)

Updated

17 years ago
Assignee: dcone → waqar
Status: ASSIGNED → NEW
(Assignee)

Comment 10

17 years ago
Waqar.. can you test this one.. I noticed you fixed a simular bug a while ago.  
If this is still broken.. assign it back the mail/new group since you fixed the 
bug with printing getting cut of from a normal web page. Thanks for your help.

Updated

17 years ago
Depends on: 64841

Updated

17 years ago
No longer depends on: 64841

Updated

17 years ago
Blocks: 64841
Reassigning to Don.
Assignee: waqar → dcone
esther@netscape.com: Could you try to reproduce the problem on Linux?. Don
thinks it was fixed by an earlier checkin?. Thanks.
This bug should have been fixed when the fix for bug 24405 was checked in.
Marking FIXED.
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 14

17 years ago
Using build 2001-04-24 on linux, printing to a hp printer with margins set to
0.50 I printed a mail message with 2 pages of text and one with 3 pages of text.
 All the text printed correctly.  I did not try this with the build that this
bug was reported on so I didn't see the problem.  Also I'm printing to a network
HP LJ 5 printer.  I will verify this since I don't see a problem printing as
stated, it the reporter still has this problem, please reopen and we'll have to
test this as a printer specific and/or printer driver specific problem.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.