rolling text causes very high CPU usage

RESOLVED DUPLICATE of bug 137584

Status

()

Firefox
General
--
major
RESOLVED DUPLICATE of bug 137584
13 years ago
13 years ago

People

(Reporter: David, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

The rolling test at the upper right corner causes over 80% CPU usage, where IE has 1% for the same page. When the mouse hovers over the rolling text, it pauses from rolling, and CPU usage goes down to 1%. When I move the mouse, it goes on rolling, and CPU usage is back to 80-90%.

Reproducible: Always

Steps to Reproduce:
1.enter http://www.ynet.co.il (it's hebrew, but you can ignore the contents)
2.CPU usage is over 80% (with pretty good computer)
3.hover over the rolling text in the upper-right corner - CPU usage down to 1%

Actual Results:  
over 80% CPU usage

Expected Results:  
much lower CPU usage. IE uses 0-2% CPU for the same page.
(Reporter)

Comment 1

13 years ago
Created attachment 202139 [details]
the source of the frame that appears to cause the high CPU usage
I see the same as the OP with today's branch build:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051107 Firefox/1.5 ID:2005110708

Also the Business page at www.msnbc.com with the 'ticker tape' scroll forces high CPU usage and garbage on refreshes to the ticker that occurs each minute or so..the text over-writes itself..

WixXP SP2, ATI 9500Pro 128meg vid card, 512Meg ram on AMD 650Mhz CPU

Comment 3

13 years ago
*** Bug 315447 has been marked as a duplicate of this bug. ***

Comment 4

13 years ago
Duplicate of bug 297457/bug 280645/bug 260340 -> bug 137584?

*** This bug has been marked as a duplicate of 137584 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.