Multiple downloads trigger when update is clicked again and the download is reset

RESOLVED FIXED in mozilla1.8.1alpha2

Status

()

Toolkit
Add-ons Manager
--
major
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Muzakkir, Assigned: rstrong)

Tracking

({fixed1.8.1})

unspecified
mozilla1.8.1alpha2
x86
Windows XP
fixed1.8.1
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

When there is a theme or extension is being updated if we click on the find updates it adds even these files to download resulting in double triple file downloads and the current download file is reset to start

Reproducible: Always

Steps to Reproduce:
1.Click on the update button to update to the newer version. when it is being downloaded click on the find updates
2.When the updates found window displays the list of downloads click Install now


Actual Results:  
It starts downloading the files that are listed.
The download is reset and duplicate are continued (If there are 2 downloads and we do this for 2 times it is downloading 6 files 4 from the two times we clicked and 2 from the original start)
We tried to close the application with the downloadd pending it says 6 files are downloading. when we did it for 2 only
When i dont want to close the application we need to click on the dont exit button many times

Expected Results:  
It should not reset the download of the theme or extension, even if the user clicks on the install multiple times it should take it as one download only

Check the attached screen shots
(Reporter)

Comment 1

12 years ago
Created attachment 202232 [details]
Screen Shot showing there are multiple downloads
(Reporter)

Comment 2

12 years ago
Created attachment 202233 [details]
Screen Shot showing there are multiple downloads
Note: we should probably just remove the button immediately to fix this bug
Assignee: nobody → robert.bugzilla
Status: UNCONFIRMED → NEW
Depends on: 329045
Ever confirmed: true
Fixed on trunk by the checkin of bug 329045. We now change the view on install to an installation view and remove the availableUpdate rdf properties which signify the item has an update to install which should prevent this from happening though I suspect if someone were to try real hard they could do this.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 2 alpha2
Keywords: fixed1.8.1
*** Bug 338894 has been marked as a duplicate of this bug. ***
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.