Last Comment Bug 315549 - [BC] ASSERTION: invalid BC damage area: 'PR_FALSE'
: [BC] ASSERTION: invalid BC damage area: 'PR_FALSE'
Status: RESOLVED FIXED
: assertion, testcase
Product: Core
Classification: Components
Component: Layout: Tables (show other bugs)
: Trunk
: All All
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
Depends on: 460637
Blocks: stirdom 323604
  Show dependency treegraph
 
Reported: 2005-11-08 05:32 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2011-12-03 05:45 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
testcase (310 bytes, text/html)
2005-11-08 05:34 PST, Martijn Wargers [:mwargers] (not working for Mozilla)
no flags Details
debug trace (3.43 KB, text/plain)
2006-08-19 08:41 PDT, Mats Palmgren (vacation)
no flags Details
wip (3.75 KB, patch)
2006-08-19 08:42 PDT, Mats Palmgren (vacation)
no flags Details | Diff | Splinter Review
Stack trace of this crash on fx2003/win98se (3.99 KB, text/plain)
2007-04-20 04:47 PDT, Kenneth Heal
no flags Details
C++ and JS stack of GMail (14.23 KB, text/plain)
2008-03-14 19:53 PDT, Ben Turner (not reading bugmail, use the needinfo flag!)
no flags Details

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2005-11-08 05:32:51 PST
See upcoming testcase.
I get this assertion in my debug build when hovering over the text:
###!!! ASSERTION: invalid BC damage area: 'PR_FALSE', file c:/mozilla/mozilla/la
yout/tables/nsTableFrame.cpp, line 4577
Comment 1 Martijn Wargers [:mwargers] (not working for Mozilla) 2005-11-08 05:34:10 PST
Created attachment 202242 [details]
testcase
Comment 2 Mats Palmgren (vacation) 2006-08-19 08:41:14 PDT
Created attachment 234594 [details]
debug trace

Sometimes we get a zero-width damage area to SetBCDamageArea().
After doing "newRect.width  = PR_MAX(1, newRect.width)" it is possible
that it's an invalid damage area (that reaches beyond the last column).
Comment 3 Mats Palmgren (vacation) 2006-08-19 08:42:42 PDT
Created attachment 234595 [details] [diff] [review]
wip

This patch fixes the assertion by adjusting 'x'...
An alternative would be to leave 'x' as is unless it's the last col.
Comment 4 Kenneth Heal 2007-04-20 04:45:41 PDT
Crashed on this too whilst testing a fx 2.0.0.3 debug build on a Win98 box.  Machine was too hosed to do very much, but what data I got I shall add as an attachment, in case anyone needs it.

Looking at #3 it looks like this one is fixed, though?
Comment 5 Kenneth Heal 2007-04-20 04:47:04 PDT
Created attachment 262239 [details]
Stack trace of this crash on fx2003/win98se
Comment 6 Bob Clary [:bc:] 2007-09-04 11:47:48 PDT
When testing the top sites with a debug trunk linux build earlier this week, I got this assertion 24985 times on 23524 pages. At the time, it made this assert the 2nd most common but since bug 394384 was fixed, that makes this the top assertion. An example reproducible with today's build is <http://telemundo.yahoo.com/_ylh=X3oDMTFhZWw1b3JpBF9TAzg5NTQyNjEEcGlkAzIwMjcyNAR0ZXN0AzAEdG1wbANlMV9pbmRleA--/r/tmc>
Comment 7 Bernd 2007-12-31 00:47:31 PST
>Sometimes we get a zero-width damage area to SetBCDamageArea().

Is that the root cause?

Comment 8 Bernd 2007-12-31 00:49:39 PST
to be more clear, I am afraid of wall papering.

>An alternative would be to leave 'x' as is unless it's the last col.

that sounds better to me, but I would like to get the zero width   SetBCDamageArea() fixed.
Comment 9 Ben Turner (not reading bugmail, use the needinfo flag!) 2008-03-14 19:53:21 PDT
Created attachment 309584 [details]
C++ and JS stack of GMail

So I get this in GMail too. Wonder if we should care more about this assertion?
Comment 10 Mats Palmgren (vacation) 2008-10-20 15:49:08 PDT
Comment on attachment 234595 [details] [diff] [review]
wip

There's a better fix in bug 460637.
Comment 11 Bernd 2011-12-03 05:45:18 PST
this is fixed by bug 460637, as the testcase involves hovering it makes no sense to check it in as it is.

Note You need to log in before you can comment on or make changes to this bug.