Unclear error dialog Unable to connect to your IMAP server

RESOLVED WONTFIX

Status

Thunderbird
Mail Window Front End
RESOLVED WONTFIX
13 years ago
9 months ago

People

(Reporter: Elliotte Rusty Harold, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051025 Firefox/1.5

Sometimes I get an alert that says, "Unable to connect to your IMAP server. You may have exceeded the maximum number of connections to this server. If so,use the Advanced IMAP Server Settings dialog to reduce the number of cached connections." This message is unclear and a poor example of error messages for two reasons.

1. Either the problem is that I've exceeded the maximum number of connections, or it isn't. Don't make me guess. If that is, the problem, tell me. No ifs. i.e. "You have exceeded the maximum number of connections to this server. Use the..." Not " You may have exceeded the maximum number of connections to this server. If so use the..." If that is not the problem, don't tell me it might be. 

2. The Advanced IMAP server settings dialog is very hard to find. It is not in the expected location, at least for a Mac User. There shouls be a button saying something like, "Open Advanced IMAP settings" or some such that opens this dialog so the user doesn't have to hunt around for it.

Reproducible: Always

Steps to Reproduce:
Fail to connect to an IMAP server




http://cafe.elharo.com/java/errormsg/

Comment 1

13 years ago
Don't make you guess?! Tell the server not to make us guess! :-) There is one kind of imap server, the Courier server, that limits the connections per ip address, and when it gets an extra connection, it just drops it. We can't tell this apart from a simple dropped connection, but we put up this message in case it's this kind of server.
(Reporter)

Comment 2

13 years ago
I'm not an IMAP expert by a long shot. Is there any way in IMAP to tell whether or not you're talking to a Courier server? 

Comment 3

13 years ago
No, there's no IMAP protocol way to tell what kind of server you're dealing with. We could look at the server greeting and guess but it would just be a guess.

Comment 4

12 years ago
Maybe related: 333661, 298974

Comment 5

12 years ago
I was asked to prefix bug IDs by the word 'bug' so that bugzilla is able to link them.

Bugs which maybe related to this one: bug 333661, bug 298974
QA Contact: front-end

Comment 6

11 years ago
Created attachment 292310 [details]
WinPcap logs of the IMAP session causing the problem

The attachment is a binary file that can be opened using Ethereal or Wireshrk

Comment 7

11 years ago
I am getting this problem as well. I spent a bit of time looking at the problem with Wireshark (Ethereal) and I think that what is happenning is that Thunderbird is trying to create a "Sent" Folder using IMAP and the server is refusing to do so for whatever reason. The problem is that the folder already exists but Thunderbird is no responding correctly to this. Probably what should happen is Thunderbird should either detect the folder or ignore the error and try writing to the Sent folder.

Updated

10 years ago
Assignee: mscott → nobody
(In reply to comment #3)
> No, there's no IMAP protocol way to tell what kind of server you're dealing
> with. We could look at the server greeting and guess but it would just be a
> guess.

David are we doing that now ?

Putting this on Bryan's radar to make it more user friendly

Comment 9

7 years ago
(In reply to comment #3)
> No, there's no IMAP protocol way to tell what kind of server you're dealing
> with. We could look at the server greeting and guess but it would just be a
> guess.

bienvenu, do you want to build on the "identify server" fix (that landed?) and accept this as ENH?  Or close this wontfix?

Comment 10

6 years ago
yeah, wontfix, we're already bending over backward to deal with this Courier issue. The identify server feature is not supposed to be used to change functionality in the client, and I really don't want to do server greeting parsing.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WONTFIX

Updated

9 months ago
Duplicate of this bug: 333661
You need to log in before you can comment on or make changes to this bug.