If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

insertion cursor in wrong place after 'select all' and then typing arrow keys

RESOLVED DUPLICATE of bug 299417

Status

Thunderbird
Message Compose Window
RESOLVED DUPLICATE of bug 299417
12 years ago
12 years ago

People

(Reporter: matt haines, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: version 1.5 (20051025)

action:
reply to message
with focus on message, type cmd-A or choose "select all" from edit menu.
hit arrow key

hitting the left or up arrows while all text is selected should move the insertion cursor to the beginning of the message. hitting the down or right arrow keys should take it to the end of the message. instead, the insertion cursor ends up at the end of the message in all instances. there are slight differences depending on which key is hit:

left arrow moves insertion cursor to the end of the last line of message, i.e. before sig separator.
up arrow moves insertion cursor to line below the last line of message, but above the sig separator.
right arrow moves insertion cursor between the two hyphens of the sig separator (right in the middle of the "--")
down arrow moves insertion cursor to very end of sig.

Reproducible: Always

Steps to Reproduce:
1. see above
2.
3.

Actual Results:  
see above

Expected Results:  
see above
(Reporter)

Comment 1

12 years ago
also, this isn't broken in 1.0.6. it's new.

Comment 2

12 years ago

*** This bug has been marked as a duplicate of 299417 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.