Crash while opening mail while junk filter copies [@ nsUInt32Array::GetAt ] [@ nsMsgDBView::CopyMessages ]

RESOLVED DUPLICATE of bug 313103

Status

MailNews Core
Filters
--
critical
RESOLVED DUPLICATE of bug 313103
13 years ago
10 years ago

People

(Reporter: BenB, Unassigned)

Tracking

({crash})

Trunk
PowerPC
Mac OS X
crash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

13 years ago
Thunderbird (1.5 RC 20051025 Mac) just crashed. I tried to open a mail. Stack shows that Thunderbird copied spam at the same time.


Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   org.mozilla.thunderbird  	0x00566990 nsUInt32Array::GetAt(unsigned) const + 8
1   org.mozilla.thunderbird  	0x005a8474 nsMsgDBView::CopyMessages(nsIMsgWindow*, unsigned*, int, int, nsIMsgFolder*) + 172
2   org.mozilla.thunderbird  	0x005a8618 nsMsgDBView::ApplyCommandToIndicesWithFolder(int, unsigned*, int, nsIMsgFolder*) + 124
3   org.mozilla.thunderbird  	0x005a9b20 nsMsgDBView::PerformActionsOnJunkMsgs() + 320
4   org.mozilla.thunderbird  	0x005a99b0 nsMsgDBView::OnMessageClassified(char const*, unsigned) + 56
5   org.mozilla.thunderbird  	0x0015f6c4 nsBayesianFilter::observeMessage(Tokenizer&, char const*, unsigned, unsigned, nsIJunkMailClassificationListener*) + 480
6   org.mozilla.thunderbird  	0x00a85864 jpeg_natural_order + 78796
7   org.mozilla.thunderbird  	0x0015e558 TokenStreamListener::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 116
8   org.mozilla.thunderbird  	0x001964e8 nsStreamConverter::OnStopRequest(nsIRequest*, nsISupports*, unsigned) + 432
9   org.mozilla.thunderbird  	0x00517f44 nsOnStopRequestEvent0::HandleEvent() + 132
10  org.mozilla.thunderbird  	0x00517944 nsStreamListenerEvent0::HandlePLEvent(PLEvent*) + 40
11  libxpcom_core.dylib      	0x10045ce4 PL_HandleEvent + 36
12  libxpcom_core.dylib      	0x10045c08 PL_ProcessPendingEvents + 128
13  com.apple.CoreFoundation 	0x9075da5c __CFRunLoopDoSources0 + 384
14  com.apple.CoreFoundation 	0x9075cf8c __CFRunLoopRun + 452
15  com.apple.CoreFoundation 	0x9075ca0c CFRunLoopRunSpecific + 268
16  com.apple.HIToolbox      	0x931831e0 RunCurrentEventLoopInMode + 264
17  com.apple.HIToolbox      	0x9326803c GetNextEventMatchingMask + 400
18  com.apple.HIToolbox      	0x93267df0 WNEInternal + 140
19  com.apple.HIToolbox      	0x93267d50 WaitNextEvent + 76
20  org.mozilla.thunderbird  	0x007fdd3c nsMacMessagePump::GetEvent(EventRecord&) + 116
21  org.mozilla.thunderbird  	0x007fdc98 nsMacMessagePump::DoMessagePump() + 48
22  org.mozilla.thunderbird  	0x0043f924 nsAppShell::Run() + 56
23  org.mozilla.thunderbird  	0x004b78fc nsAppStartup::Run() + 60
24  org.mozilla.thunderbird  	0x0000ecac XRE_main + 3792
25  org.mozilla.thunderbird  	0x0000a01c start + 432
26  org.mozilla.thunderbird  	0x00009e9c start + 48

Thread 1:
0   libSystem.B.dylib        	0x9001f20c select + 12
1   libnspr4.dylib           	0x0301f140 poll + 392
2   libnspr4.dylib           	0x0301b8f4 PR_OpenDir + 944
3   org.mozilla.thunderbird  	0x0051eff0 nsSocketTransportService::Poll(unsigned*) + 116
4   org.mozilla.thunderbird  	0x0051f73c nsSocketTransportService::Run() + 432
5   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
6   libnspr4.dylib           	0x0301cd80 PR_Select + 852
7   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 2:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libxpcom_core.dylib      	0x1004b41c TimerThread::Run() + 412
5   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
6   libnspr4.dylib           	0x0301cd80 PR_Select + 852
7   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 3:
0   libSystem.B.dylib        	0x9002b8a8 semaphore_wait_signal_trap + 8
1   libSystem.B.dylib        	0x9003001c pthread_cond_wait + 488
2   libnspr4.dylib           	0x03017eb8 PR_WaitCondVar + 116
3   libnspr4.dylib           	0x03018234 PR_Wait + 48
4   libxpcom_core.dylib      	0x10045e68 PL_WaitForEvent + 56
5   libxpcom_core.dylib      	0x1004752c nsEventQueueImpl::WaitForEvent(PLEvent**) + 56
6   libxpcom_core.dylib      	0x1004c20c nsProxyObject::PostAndWait(nsProxyObjectCallInfo*) + 272
7   libxpcom_core.dylib      	0x1004c4ec nsProxyObject::Post(unsigned, nsXPTMethodInfo*, nsXPTCMiniVariant*, nsIInterfaceInfo*) + 368
8   libxpcom_core.dylib      	0x1004dc44 nsProxyEventObject::CallMethod(unsigned short, nsXPTMethodInfo const*, nsXPTCMiniVariant*) + 52
9   libxpcom_core.dylib      	0x1005cdc4 PrepareAndDispatch + 560
10  libxpcom_core.dylib      	0x1005d768 SharedStub + 112
11  org.mozilla.thunderbird  	0x00121674 nsImapProtocol::ReleaseUrlState(int) + 132
12  org.mozilla.thunderbird  	0x00122bbc nsImapProtocol::ProcessCurrentURL() + 1952
13  org.mozilla.thunderbird  	0x0012211c nsImapProtocol::ImapThreadMainLoop() + 296
14  org.mozilla.thunderbird  	0x00121898 nsImapProtocol::Run() + 72
15  libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
16  libnspr4.dylib           	0x0301cd80 PR_Select + 852
17  libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 4:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libnspr4.dylib           	0x03018234 PR_Wait + 48
5   org.mozilla.thunderbird  	0x0012206c nsImapProtocol::ImapThreadMainLoop() + 120
6   org.mozilla.thunderbird  	0x00121898 nsImapProtocol::Run() + 72
7   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
8   libnspr4.dylib           	0x0301cd80 PR_Select + 852
9   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 5:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libnspr4.dylib           	0x03018234 PR_Wait + 48
5   org.mozilla.thunderbird  	0x0012206c nsImapProtocol::ImapThreadMainLoop() + 120
6   org.mozilla.thunderbird  	0x00121898 nsImapProtocol::Run() + 72
7   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
8   libnspr4.dylib           	0x0301cd80 PR_Select + 852
9   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 6:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   org.mozilla.thunderbird  	0x004dd7b4 nsIOThreadPool::ThreadFunc(void*) + 116
5   libnspr4.dylib           	0x0301cd80 PR_Select + 852
6   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 7:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libnspr4.dylib           	0x03018234 PR_Wait + 48
5   org.mozilla.thunderbird  	0x0012206c nsImapProtocol::ImapThreadMainLoop() + 120
6   org.mozilla.thunderbird  	0x00121898 nsImapProtocol::Run() + 72
7   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
8   libnspr4.dylib           	0x0301cd80 PR_Select + 852
9   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 8:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   org.mozilla.thunderbird  	0x0084c028 nsHostResolver::GetHostToLookup(nsHostRecord**) + 132
5   org.mozilla.thunderbird  	0x0084c37c nsHostResolver::ThreadFunc(void*) + 184
6   libnspr4.dylib           	0x0301cd80 PR_Select + 852
7   libSystem.B.dylib        	0x9002b200 _pthread_body + 96

Thread 9:
0   libSystem.B.dylib        	0x90053f68 semaphore_timedwait_signal_trap + 8
1   libSystem.B.dylib        	0x90053dc8 pthread_cond_timedwait + 672
2   libnspr4.dylib           	0x03017c68 PR_Unlock + 300
3   libnspr4.dylib           	0x03017ecc PR_WaitCondVar + 136
4   libnspr4.dylib           	0x03018234 PR_Wait + 48
5   org.mozilla.thunderbird  	0x0012206c nsImapProtocol::ImapThreadMainLoop() + 120
6   org.mozilla.thunderbird  	0x00121898 nsImapProtocol::Run() + 72
7   libxpcom_core.dylib      	0x10048834 nsThread::Main(void*) + 56
8   libnspr4.dylib           	0x0301cd80 PR_Select + 852
9   libSystem.B.dylib        	0x9002b200 _pthread_body + 96
(Reporter)

Comment 1

13 years ago
Note: The mail I tried to open was in a different folder, i.e. neither INBOX nor the spam folder.
Severity: normal → critical

Comment 2

13 years ago
Dup of bug 313103?

Comment 3

12 years ago
Stack matches bug 220346, resolving duplicate.

*** This bug has been marked as a duplicate of 220346 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 4

12 years ago
Reopening, my bad. My comment 2 was more accurate; this is likely a duplicate of bug 313103.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

12 years ago
Resolving dup per my comment 4.

*** This bug has been marked as a duplicate of 313103 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
(Assignee)

Updated

7 years ago
Crash Signature: [@ nsUInt32Array::GetAt ] [@ nsMsgDBView::CopyMessages ]
You need to log in before you can comment on or make changes to this bug.