listing folders of IMAP account (marking junk, not junk and so). THere was some strange behavior ... [@ nsUInt32Array::GetAt]

RESOLVED DUPLICATE of bug 339518

Status

MailNews Core
Networking: IMAP
--
critical
RESOLVED DUPLICATE of bug 339518
12 years ago
9 years ago

People

(Reporter: timeless, Assigned: Bienvenu)

Tracking

({crash, topcrash})

1.8 Branch
crash, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

12 years ago
also note bug 296292 which was reported against non windows (hence os:all)

Incident ID: 10227634
Stack Signature	nsUInt32Array::GetAt 1c7532a4
Product ID	Thunderbird15
Build ID	2005090804
Trigger Time	2005-10-05 01:26:27.0
Platform	Win32
Operating System	Windows NT 4.0 build 1381
Module	thunderbird.exe + (0042b14a)
URL visited	
User Comments	I was listing folders of IMAP account (marking junk, not junk and
so). THere was some strange behavior ... after selecting mail header of some
emails i saw bodyes of other emails. I was testing this behavior, but in short
whle the Thunderbird crashed down
Since Last Crash	240391 sec
Total Uptime	240391 sec
Trigger Reason	Access violation
Source File, Line No.
e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsUInt32Array.cpp,
line 160
Stack Trace 	
nsUInt32Array::GetAt 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsUInt32Array.cpp,
line 160]
nsMsgDBView::ApplyCommandToIndicesWithFolder 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 2313]
nsMsgDBView::PerformActionsOnJunkMsgs 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 2905]
nsMsgDBView::OnMessageClassified 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp,
line 2841]
MessageObserver::analyzeTokens 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/extensions/bayesian-spam-filter/src/nsBayesianFilter.cpp,
line 1259]
nsStreamListenerTee::OnStopRequest 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsStreamListenerTee.cpp,
line 65]
nsStreamListenerEvent0::HandlePLEvent 
[e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp,
line 122]
david, I'm seeing this crash (every so often) when I mark messages as junk.

See TB12595145Z

nsUInt32Array::GetAt  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsUInt32Array.cpp, line 160]
nsMsgDBView::ApplyCommandToIndicesWithFolder  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2313]
nsMsgDBView::PerformActionsOnJunkMsgs  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2905]
nsMsgDBView::OnMessageClassified  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2841]
MessageObserver::analyzeTokens  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/extensions/bayesian-spam-filter/src/nsBayesianFilter.cpp, line 1259]
nsOnStopRequestEvent0::HandleEvent  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp, line 320]
nsStreamListenerEvent0::HandlePLEvent  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp, line 122]
shdocvw.dll + 0x150c24 (0x778b0c24)
nsWebBrowserPersist::SaveURIInternal  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/embedding/components/webbrowserpersist/src/nsWebBrowserPersist.cpp, line 1229]
0x8b016a01

A slightly different stack, see TB12254527E

nsUInt32Array::GetAt  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsUInt32Array.cpp, line 160]
nsMsgDBView::ApplyCommandToIndicesWithFolder  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2313]
nsMsgDBView::PerformActionsOnJunkMsgs  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2905]
nsMsgDBView::OnMessageClassified  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2841]
MessageObserver::analyzeTokens  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/extensions/bayesian-spam-filter/src/nsBayesianFilter.cpp, line 1259]
nsStreamListenerTee::OnStopRequest  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsStreamListenerTee.cpp, line 65]
nsStreamListenerEvent0::HandlePLEvent  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp, line 122]
shdocvw.dll + 0x150c24 (0x778b0c24)
nsWebBrowserPersist::SaveURIInternal  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/embedding/components/webbrowserpersist/src/nsWebBrowserPersist.cpp, line 1229]
0x8b016a01

And, just now:  TB12951423Y (too soon for a talkback report)

I'm using version 1.5 (20051025)
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: listing folders of IMAP account (marking junk, not junk and so). THere was some strange behavior ... [@ nsUInt32Array::GetAt] → listing folders of IMAP account (marking junk, not junk and so). THere was some strange behavior ... [@ nsUInt32Array::GetAt]
(Reporter)

Updated

12 years ago
Version: 1.7 Branch → 1.8 Branch

Comment 2

12 years ago
*** Bug 320493 has been marked as a duplicate of this bug. ***
seeing this with 2005102519

see TB12951423Y

nsUInt32Array::GetAt  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/util/nsUInt32Array.cpp, line 160]
nsMsgDBView::ApplyCommandToIndicesWithFolder  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2313]
nsMsgDBView::PerformActionsOnJunkMsgs  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2905]
nsMsgDBView::OnMessageClassified  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/base/src/nsMsgDBView.cpp, line 2841]
MessageObserver::analyzeTokens  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/mailnews/extensions/bayesian-spam-filter/src/nsBayesianFilter.cpp, line 1259]
nsStreamListenerTee::OnStopRequest  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsStreamListenerTee.cpp, line 65]
nsStreamListenerEvent0::HandlePLEvent  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/netwerk/base/src/nsAsyncStreamListener.cpp, line 122]
0x778b0c24
nsWebBrowserPersist::SaveURIInternal  [e:/builds/tinderbox/Tb-Mozilla1.8/WINNT_5.0_Depend/mozilla/embedding/components/webbrowserpersist/src/nsWebBrowserPersist.cpp, line 1229]
0x8b016a01

Comment 4

12 years ago
this is showing up as a top crash in thunderbird 1.5 RC2.
Flags: blocking1.8.1?
Keywords: topcrash

Comment 5

12 years ago
Stack matches bug 220346, resolving duplicate.

*** This bug has been marked as a duplicate of 220346 ***
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE

Comment 6

12 years ago
Reopening, my bad. Setting Platform=All as I'm seeing this using Thunderbird 1.5.0.1 on Mac OS X.
Status: RESOLVED → REOPENED
Keywords: crash
Hardware: PC → All
Resolution: DUPLICATE → ---

Comment 7

12 years ago
Thunderbird version 1.5.0.2 (20060308); Mac OS X 10.3.9

 A workaround for this bug appears to be to wait for junk processing to finish before changing window views.

 This afternoon I was too impatient and Thunderbird crashed. Talkback didn't launch for some reason. The CrashReporter log shows a stack trace the same as reported in Bug 315922 (in which Comment #4 suggests it is a duplicate of this bug). The stack trace is substantially similar to those above.

 Talkback currently shows 500 crashes where the Stack Signature contains 'nsuint32array::getat' for Thunderbird 1.5, predominantly on Windows. If my experience with Talkback failing to launch for this crash is representative of a significant number of users, there is significant under-reporting of this problem. Perhaps this bug should be a blocker?

------------------------------------------------------------

Date/Time:      2006-05-10 14:35:33 +1200
OS Version:     10.3.9 (Build 7W98)
Report Version: 2

Command: thunderbird-bin
Path:    /Applications/Thunderbird.app/Contents/MacOS/thunderbird-bin
Version: 1.5.0.2 (1.5.0.2)
PID:     360
Thread:  0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_PROTECTION_FAILURE (0x0002) at 0x00000000

Thread 0 Crashed:
0   org.mozilla.thunderbird      0x00568c18 nsUInt32Array::GetAt(unsigned int) const + 0x8
1   org.mozilla.thunderbird      0x005aa770 nsMsgDBView::CopyMessages(nsIMsgWindow*, unsigned int*, int, int, nsIMsgFolder*) + 0xac
2   org.mozilla.thunderbird      0x005aa914 nsMsgDBView::ApplyCommandToIndicesWithFolder(int, unsigned int*, int, nsIMsgFolder*) + 0x7c
3   org.mozilla.thunderbird      0x005abe1c nsMsgDBView::PerformActionsOnJunkMsgs() + 0x140
4   org.mozilla.thunderbird      0x005abcac nsMsgDBView::OnMessageClassified(char const*, unsigned int) + 0x38
5   org.mozilla.thunderbird      0x0015fde4 nsBayesianFilter::observeMessage(Tokenizer&, char const*, unsigned int, unsigned int, nsIJunkMailClassificationListener*) + 0x1e0
6   org.mozilla.thunderbird      0x00a88a74 0x1000 + 0xa87a74
7   org.mozilla.thunderbird      0x0015ec78 TokenStreamListener::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) + 0x74
8   org.mozilla.thunderbird      0x00196c1c nsStreamConverter::OnStopRequest(nsIRequest*, nsISupports*, unsigned int) + 0x1b0
9   org.mozilla.thunderbird      0x00519d58 nsOnStopRequestEvent0::HandleEvent() + 0x84
10  org.mozilla.thunderbird      0x00519758 nsStreamListenerEvent0::HandlePLEvent(PLEvent*) + 0x28
11  libxpcom_core.dylib          0x10046930 PL_HandleEvent + 0x24
12  libxpcom_core.dylib          0x10046854 PL_ProcessPendingEvents + 0x80
13  com.apple.CoreFoundation     0x901c3b90 __CFRunLoopDoSources0 + 0x1fc
14  com.apple.CoreFoundation     0x901c1448 __CFRunLoopRun + 0x1b0
15  com.apple.CoreFoundation     0x901c5d74 CFRunLoopRunSpecific + 0x148
16  com.apple.HIToolbox          0x92886e10 RunCurrentEventLoopInMode + 0xac
17  com.apple.HIToolbox          0x92889eb0 GetNextEventMatchingMask + 0x1a0
18  com.apple.HIToolbox          0x9289d988 WNEInternal + 0xa0
19  com.apple.HIToolbox          0x928ae6a0 WaitNextEvent + 0x4c
20  org.mozilla.thunderbird      0x00800584 nsMacMessagePump::GetEvent(EventRecord&) + 0x74
21  org.mozilla.thunderbird      0x008004e0 nsMacMessagePump::DoMessagePump() + 0x30
22  org.mozilla.thunderbird      0x0044154c nsAppShell::Run() + 0x38
23  org.mozilla.thunderbird      0x004b9550 nsAppStartup::Run() + 0x3c
24  org.mozilla.thunderbird      0x0000ef54 XRE_main + 0x1114
25  org.mozilla.thunderbird      0x0000a01c start + 0x1b0
26  org.mozilla.thunderbird      0x00009e9c start + 0x30

[Remaining Thread and binary log omitted. If it's required, please let me know.]

Updated

12 years ago
Flags: blocking-thunderbird2?

Comment 8

12 years ago
*** Bug 315922 has been marked as a duplicate of this bug. ***

Comment 9

12 years ago
I think this crash may have been fixed by the patch in bug 339518. Could anyone test and see? (Patch is in on trunk and branch, so either works.)

Comment 10

12 years ago
I wonder why the call to nsMsgDBView::CopyMessages only shows up in the stack in comment 7...

Copy messages is doing something like |key = m_keys.GetAt(viewIndex);|. I'm assuming that m_keys's count has been reduced to 0 in nsMsgDBView::Close when someone switches a folder. 

I am unsure of where this GetAt call goes. The stack says it goes to nsUInt32Array, but wouldn't it go to nsMsgKey nsMsgDBView::GetAt in nsMsgDBView first and just return nsMsgKey_None since the index is greater than the size of the array?

Comment 11

12 years ago
OK. So m_keys.GetAt is acting directly on the array. 

Anyway, my patch in bug 339518 will fix this since it will prevent us trying to perform these commands on messages if we've switched a folder.

*** This bug has been marked as a duplicate of 339518 ***
Status: REOPENED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → DUPLICATE

Updated

12 years ago
Flags: blocking-thunderbird2?
Product: Core → MailNews Core
Crash Signature: [@ nsUInt32Array::GetAt]
You need to log in before you can comment on or make changes to this bug.