Closed Bug 315930 Opened 14 years ago Closed 14 years ago

"Publish Entire Calendar" does not export tasks

Categories

(Calendar :: Internal Components, defect)

x86
Windows 2000
defect
Not set

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: ssitter, Assigned: jminta)

References

Details

(Keywords: dataloss)

Attachments

(1 file, 1 obsolete file)

Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20051110 Mozilla Sunbird/0.3a1+

"Publish Entire Calendar" does not export tasks, only events.

Steps to Reproduce:
- create new calendar
- create one event
- create one task
- select "Publish Entire Calendar" for calendar and export to a local *.ics file
- open *.ics file in text editor

Actual Results:
- there is only one VEVENT element in *.ics file

Expected Results:
- one VEVENT and one VTODO element should be in *.ics file
Attached patch use correct filter (obsolete) — Splinter Review
You don't get any tasks unless you specify a filter for completed or not.
Assignee: shaver → jminta
Status: UNCONFIRMED → ASSIGNED
Attachment #202663 - Flags: first-review?(mvl)
Comment on attachment 202663 [details] [diff] [review]
use correct filter

You shouls use ITEM_FILTER_ALL_ITEMS. That will always get all items.
Attachment #202663 - Flags: first-review?(mvl) → first-review-
But from looking better, that will also set ITEM_FILTER_CLASS_OCCURRENCES, so will occurrences, rather then items.
I think we should change the idl though, to add a case for this. That way, you don't have to update all callers when adding a filter.
(In reply to comment #3)
> But from looking better, that will also set ITEM_FILTER_CLASS_OCCURRENCES, so
> will occurrences, rather then items.

If I'm reading this correctly, that's not the case:

        ITEM_FILTER_ALL_ITEMS = 0x0000FFFF
ITEM_FILTER_CLASS_OCCURRENCES = 0x00010000

So your original suggestion should be fine, I think.
uses ITEM_FILTER_ALL_ITEMS.  This doesn't seem like the right bug to start messing with the idl.
Attachment #202663 - Attachment is obsolete: true
Attachment #202691 - Flags: first-review?(mvl)
Comment on attachment 202691 [details] [diff] [review]
use correct filter v2

r=mvl
Attachment #202691 - Flags: first-review?(mvl) → first-review+
patch checked in
Status: ASSIGNED → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
*** Bug 316259 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.