Firefox opens new empty tabs when i try to connect to localhost

RESOLVED DUPLICATE of bug 167320

Status

()

--
major
RESOLVED DUPLICATE of bug 167320
13 years ago
13 years ago

People

(Reporter: kkarpieszuk, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8) Gecko/20051025 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; pl; rv:1.8) Gecko/20051025 Firefox/1.5

hi

I have Apache 2.0 on localhost and it works very well except when it have to serve one file to Firefox. Every other files, opens ok in Firefox, but not this one (index.php if name is important). To explain it better, i connect to this file typing http://127.0.0.1/alli/index.php. When i type http://127.0.0.1/alli/ file opens very good. Also other files in /alli folder, opens very goos.

But what happens when i try to open http://127.0.0.1/alli/? When i try to do this, firefox doesn`t open file but open new tab, and new tab, and other one... it opens new tabs without finish, i have to close Firefox.

Other importants:
- other brwsers (Opera, Epiphany, Konqueror) works good with this file
- i do not get any logs in apache about errors, even warnings
- i do not have any logs in console when i open Firefox in xterm
- i do noc have any logs in javascript console
- when i save index.php to index.html (using other browsers) and try to open it in firefox (not via 127.* but opening it from local folder), firefox opens it good
- index.php is good semantic xhtml document

I am not an expert but it looks for me that Firefox got some diffrent http headers from apache and works as it works.

Reproducible: Always

Comment 1

13 years ago
Could you attach index.php? Maybe it's somehow calling a function to open a new tab/page?
(Reporter)

Comment 2

13 years ago
ok, i can, but... now everything works ok :( I cannot explain, i didn`t change any setting (in firefox and apache, even in mysql) but firefox now open inde.php well.

Here is html of index.php, everything looks ok

==========
<!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 4.01//EN" "http://www.w3.org/TR/html4/transitional.dtd">
<html>
<head>
<meta http-equiv="Content-type" content="text/html;charset=iso-8859-2" />
<title>Allina</title>
<link rel="STYLESHEET" href="styl.css" type="text/css">
</head>
<body>

<div id="lewy">
<a href="index.php" accesskey="1">Pocz±tek</a>
<ul>
   <li>Transakcje</li>
   <ul>
    <li><a href="transakcja.php" accesskey="T">Dodaj</a> (T)</li>
    <li>Zmieñ status</li>
    <li>Szukaj</li>
   </ul>
   <li>Produkty</li>
   <ul>
    <li><a href="produkty.php" accesskey="P">Przegl±daj</a> (P)</li>
    <li><a href="dodajprodukt.php">Dodaj</a></li>
    <li>Usuñ</li>
    <li>Szukaj</li>
   </ul>
   <li>Kupuj±cy</li>
   <ul>
    <li>Dodaj</li>
    <li>Zmieñ dane</li>
    <li>Szukaj</li>
   </ul>
</ul></div>
<div id="prawy">
<h3>index</h3> </div>
</body>
</html> 
=========

Other files - which worked well - instead of "<h3>index</h3>" have few more html markups.

Comment 3

13 years ago
Reopen if it happens again.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Reporter)

Comment 4

13 years ago
now i have thesame problem but at other site (site is password protected, co i cannot give you a link).

there is some form which sent much of data after pressing a buuton. But after few seconds (~30 sec) new empty tabs starts to open.

I tried thesame site in opera 8.5 and after ~30 sec opera shows:

===========
Connection closed by remote server

You tried to access the address http://allegro.pl/sell_some_again.php, which is currently unavailable. Please make sure that the Web address (URL) is correctly spelled and punctuated, then try reloading the page.
Make sure your Internet connection is active and check whether other applications that rely on the same connection are working.
Check that the setup of any Internet security software is correct and does not interfere with ordinary Web browsing.
If you are behind a firewall on a Local Area Network and think this may be causing problems, talk to your systems administrator.
Try pressing the F12 key on your keyboard and disabling proxy servers, unless you know that you are required to use a proxy to connect to the Internet. Reload the page.
=============

So that looks that Firefox cannot react for some server headers about unavailability of site (maybe error 404, unfortunetlly opera doesn`t inform whoat kind of error it is)
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
That sounds like bug 167320...

Comment 6

13 years ago

*** This bug has been marked as a duplicate of 167320 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.