URL incorrectly highlighted in message pane

RESOLVED DUPLICATE of bug 133016

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 133016
13 years ago
13 years ago

People

(Reporter: Io McKinnon, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 (ax)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7 (ax)

Thunderbird incorrectly highlights a URL in test mail, leaving out the last part of the URL and rendering it useless. This occurs when viewing the message. The URL is http://www.bvhd.dk/index.php?id=371&cmd=setfixed&sFK=approve&rU=1308&fD[_FIELDLIST]=uid&fD[hidden]=0&aC=d4176409
and the client only highlights up to 
http://www.bvhd.dk/index.php?id=371&cmd=setfixed&sFK=approve&rU=1308&fD[_FIELDLIST
.

Reproducible: Always

Steps to Reproduce:
1. Mail self text mail containing above URL
2. Click on incorrectly highlighted text
3. Broken link.


Expected Results:  
The client should highlight the entirity of the URL in the message.

Comment 1

13 years ago
This is covered already by bug 133016. Note that '[' and ']' must be escaped when used in a URL, so the URLs you quote are technically invalid.

*** This bug has been marked as a duplicate of 133016 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.