Default component when creating a bug

VERIFIED WONTFIX

Status

()

P3
enhancement
VERIFIED WONTFIX
13 years ago
5 years ago

People

(Reporter: bugzilla-mozilla, Assigned: justdave)

Tracking

Details

(Reporter)

Description

13 years ago
See bug 36843 for dataloss scenario - to summarise:
1) Take a long time entering a detailed bug report.
2) submit, then curse as bugzilla tells you off for failing to select a component.
3) Obey instruction telling you to press 'back'.
4) (browser/time dependent) Observe a rather empty form - scream very loudly!

See bug 145009 for a method by which this dataloss can be prevented - the bug entry form can specify a default component for each product. This bug is a request to use the method in bug 145009 on b.m.o - many products have a "General" component already, or a meta-component of "Default" or "Unspecified" could be created assigned to nobody, whose first goal is to get it filed properly...

Comment 1

13 years ago
i'd like to vote against this. bugzilla should instead store your entire submission and give you the enter_bug page prefilled w/ the data you have.
Assignee: asa → justdave
Component: Bugzilla: Keywords & Components → Bugzilla: Other b.m.o Issues
QA Contact: timeless → myk
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> bugzilla should ... store your entire
> submission and give you the enter_bug page prefilled w/ the data you have.

I agree (and have had a vote on the bug about that for some time)

However that is part of bug 36843 (in particular bug 36843 comment 5), which is over 5 years old and showing no signs of progress, whereas this is something that can be done with just template and/or component changes on b.m.o to prevent one of the more common triggers for such data loss (new users who may not be aware that selecting a component is mandatory, old users may simply forget).
Assignee: justdave → justdave
Priority: -- → P3
If we select one by default, that component will get a lot of bugs misfiled in it...

Gerv
(Reporter)

Comment 4

12 years ago
(In reply to comment #3)
> If we select one by default, that component will get a lot of bugs misfiled in
> it...

I believe that is the idea... and then the reporter can fix this by filing it in the correct component or have a cleanup task invite him to do so at a later date, rather than the submissing being discarded due to not having selected a component.

(the text of the page which discards the submitted bug report suggests "press back" as a workaround, and this will indeed retrieve the data on some browsers, but others consider it insecure to cache the form contents on https pages and avoid doing so by design.)

This (*cough* - fixes) enhancement will be unnecessary if/when bug 36843 is fixed. It is a workaround to avoid some dataloss scenarios created by that bug, and will as you say have a down side that some reporters once the bug is accepted by the system won't bother to correct the component afterward (probably even if the component is called "(!!! SELECT A COMPONENT !!!)".


I see that I reported this... in fact I am no longer as strongly affected by the underlying problem (having switched to almost exclusive use of Firefox), so unless anyone else wants to champion this bug, I propose it be WONTFIX-ed in favour of making Bugzilla itself behave like any other well-behaved webapp as described in bug 36843 comment 5 and/or bug 36843 comment 28.
Severity: normal → enhancement
Keywords: dataloss
WONTFIXing, as per comment #4.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Yep, bug 36843 is the way.
Status: RESOLVED → VERIFIED
QA Contact: myk → reed
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.