Search options disappear

RESOLVED DUPLICATE of bug 319196

Status

()

Firefox
Search
--
major
RESOLVED DUPLICATE of bug 319196
13 years ago
12 years ago

People

(Reporter: Gee, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---
Bug Flags:
blocking1.8.0.5 -

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051107 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8) Gecko/20051107 Firefox/1.5

There was an update 14/11/2005 and after a restart of Mozilla, the search options disappeared completely making it impossible to add search engines to the list. Presently there is no list and cannot do a search.

Reproducible: Always
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5 Branch
Assuming you mean the searchplugins: it is always advisable to store the searchplugins in your profile, that way they will always survive an update and will not be replaced by a new default set.
Don't know what has gone wrong but have you tried reinstalling Firefox?

Comment 2

13 years ago
Related to/duplicate of bug 315698 -> bug 311626?

Comment 3

13 years ago
Ditto problem, on upgrade to v1.5, user installed search engines have been deleted.

Comment 4

13 years ago
This has happened to me twice now. a week after installing firefox 1.5 all of the search engines vanish from teh top right box and none can be added.

This isn't the same as lossing the extra search engines that you've choosen because the defaults have been installed.

Comment 5

13 years ago
The following Javascript errors are thrown when trying to install a new search engine:

Error: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSidebar.js :: anonymous :: line 192"  data: no]
Source File: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSidebar.js
Line: 192

Error: uncaught exception: [Exception... "Component returned failure code: 0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE) [nsIJSCID.getService]"  nsresult: "0x80570016 (NS_ERROR_XPC_GS_RETURNED_FAILURE)"  location: "JS frame :: file:///C:/Program%20Files/Mozilla%20Firefox/components/nsSidebar.js :: anonymous :: line 192"  data: no]

Comment 6

13 years ago
experiencing the same problem - windox xp sp2 rv:1.8) Gecko/20051111 Firefox/1.5

Comment 7

13 years ago
Work around discovered, but it's not pretty.

1. Cut your extensions/bookmarks from your C:\Documents and Settings\ProfileName\Application Data\Mozilla\Firefox\Profiles\random_string.default\ directory and paste them somewhere else (i.e., your desktop).
2. Delete the C:\Documents and Settings\ProfileName\Application Data\Mozilla\ folder entirely.
3. Open Firefox and close it once it has launched.
4. Cut your extensions/bookmarks from wherever you had saved them to.
5. Paste them back into the newly created C:\Documents and Settings\ProfileName\Application Data\Mozilla\Firefox\Profiles\random_string.default\ directory and the problem should be fixed.

It's a stop-gap (albeit a simpler one than running a total reinstall), but it did the trick for me. Still be nice to see a follow up from the big guns at Mozilla, though...

Comment 8

13 years ago
I had the same issue.  Verified that the ugly work-around works, too.

ian
Flags: blocking1.8.0.5?
Flags: blocking-firefox2?

Comment 9

12 years ago
while using Firefox (it doesn't matter the build) if suddently the computers hungs up and you need to reboot it, it may happen that the search engines list may dissapear. that's because localstore.rdf file from you profile directory gets corrupted.

create a new profile and copy the localstore.rdf from the new profile directory where you old profile exists, overwriting it. then delete the new profile.
We have a different search service now, please renominate for Fx2 if this is reproduced using Bon Echo Alpha 2 or later.
Flags: blocking-firefox2?
This is likely caused by the "corrupt localStore.rdf" bug that was fixed for 1.8.0.2 in bug 307558. This means that the bug should no longer occur when updating 1.5.0.2 or later.
*** Bug 321300 has been marked as a duplicate of this bug. ***
We think this bug is actually fixed (see comment 11). Should we close this bug, or leave it open to see if there are any dupes from firefox 1.5.0.4 folks? (so far there haven't been any).
Flags: blocking1.8.0.5? → blocking1.8.0.5-
If you think it's fixed, it should be FIXED, no?

If we find out later that we were on, it'll be REOPENED.  Maybe I'm just not understanding the question?

Comment 15

12 years ago
Confirmed. Bug still in existance in Mozilla Firefox/1.5.0.4, but the workaround fixed it just as well.
Any remaining cases of this (that weren't fixed by bug 307558) are being tracked by bug 319196, so duping forward.

*** This bug has been marked as a duplicate of 319196 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
The "workaround" works because you're backing up the files that get overwritten when encountering the bug, and then restoring them afterwards.

To be clear, the bug this has been duped to is for tracking cases where the bookmarks are also gone, there was no mention of missing bookmarks in this bug. I imagine this is really a dupe of the fixed bug, but Josephus is encountering the bug this is duped to.

Comment 18

12 years ago
I believe Firefox recently updated itself (About 1 week to 2 weeks ago) and now the search engine options are ALL missing and I can't add any. NOT RESOLVED.
(In reply to comment #18)
> I believe Firefox recently updated itself (About 1 week to 2 weeks ago) and now
> the search engine options are ALL missing and I can't add any. NOT RESOLVED.

It is resolved: DUPLICATE, of bug 319196. That just means the issue has already been reported. CC yourself to bug 319196 if you want to track progress.

Comment 20

12 years ago
i fix it just adding a new theme and puff......back again !
You need to log in before you can comment on or make changes to this bug.