If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

eu default search engine should be google no a magnifying glass that breaks search

VERIFIED FIXED

Status

Mozilla Localizations
Other
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: tracy, Assigned: Ibon Igartua)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
 
(Reporter)

Comment 1

12 years ago
seen on l10n build of eu on 11/15

-launch the build with a new profile
notice search icon is a magnifying glass
-enter a search topic and hit enter
no web search is performed
-click the magnifying glass and select Google
-then perform a search
google search works

tested results:
no search engine is set as the default, web search doesn't work

expected results:
Google is set as the default search engine (which works)
Are there any JS Console errors if you set the showInConsole pref to true? Presumably this is due to a misconfigured search plugin, which could be related to bug 298562. The search bar should be handling that, though, by defaulting to Google.
Could you post the value of the browser.search.selectedEngine pref from a new profile?
(Reporter)

Comment 4

12 years ago
two errors appaear in the JSconsole that weren't there without that pref on. However I can't read the language.  Where does the browser.search.selectedEngine pref live? browser.search.defaultenginename is set to Google.
Could you paste the errors here?

You're right, I was mistaken, selectedEngine isn't set by default, but browser.search.defaultenginename is. It seems to be set correctly though so it shouldn't be the issue.
(Reporter)

Comment 6

12 years ago
Errorea: Hautatzaile espero zen.  Hautatzaile oker bat dela eta arau ezarpena albo batetara utzi da.
Iturburu-fitxategia: http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:eu:official
Lerroa: 3

Errorea: Ezusteko fitxategi amaiera 'baliogabeko arau ezarpeneko } ixterakoan' bilatzerakoan.
Iturburu-fitxategia: http://www.google.com/firefox?client=firefox-a&rls=org.mozilla:eu:official
Lerroa: 4
Ok, this is happening because the eu localizers have changed the name of the Google search plugin (http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/searchplugins/google-eu.src#4). That change should probably be reverted.
(It should be just "Google", not "Google [eu]")
(Assignee)

Comment 9

12 years ago
(In reply to comment #7)
> Ok, this is happening because the eu localizers have changed the name of the
> Google search plugin
> (http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/searchplugins/google-eu.src#4).
> That change should probably be reverted.
> 

 I did the localization of the google.src file

 It's mandatory to change the name of the file/plugin in case we are localizing it. I think that the problem is here:

http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/chrome/browser-region/region.properties#13

 I read in the mozilla-l10n list than the name there had to be the same placed in the name attr value in the src file ... but it seems that it doesn't work!

 could it be because of the "space" ?
Why is it mandatory? None of the other localizations seem to do it. You could alternatively change http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/chrome/browser-region/region.properties#21 to match, but I don't see why you'd want it to have a different name to begin with.
Seems like some localizations do change the name, but change region.properties to match. I've just noticed that this same problem occurs with BG (bg/browser/searchplugins/google-bg.src has "Google.bg" while bg/browser/chrome/browser-region/region.properties has "Google"). Seems to me like it'd be easiest to just keep the name the same for all of them.
(Assignee)

Comment 12

12 years ago
(In reply to comment #10)
> Why is it mandatory? None of the other localizations seem to do it. You could
> alternatively change
> http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/chrome/browser-region/region.properties#21
> to match, but I don't see why you'd want it to have a different name to begin
> with.
> 

 I missed that line (21) ... I did only change the line No. 13

 Axel: what do you want me to do? ... I see two alternatives:

alt 1.- change the value here (http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/searchplugins/google-eu.src#4) to just "Google" and fix it here as well (http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/chrome/browser-region/region.properties#13)

alt 2.- Just change the value here (http://lxr.mozilla.org/l10n-mozilla1.8/source/eu/browser/chrome/browser-region/region.properties#21) to "Google [eu]"

Comment 13

12 years ago
Just using "Google" should be good enough.
(Assignee)

Comment 14

12 years ago
Created attachment 203460 [details] [diff] [review]
using just "Google" instead of "Google [eu]"
Attachment #203460 - Flags: approval-l10n?

Updated

12 years ago
Attachment #203460 - Flags: approval-l10n? → approval-l10n+
(Assignee)

Comment 15

12 years ago
commited in CVS!
(Assignee)

Updated

12 years ago
Status: NEW → ASSIGNED

Comment 16

12 years ago
Can this bug be closed?
(Assignee)

Comment 17

12 years ago
(In reply to comment #16)
> Can this bug be closed?
> 

  I've just tested "21-Nov-2005 13:53" latest-mozilla1.8-l10n build and the bug is fixed
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.