Closed Bug 316849 Opened 16 years ago Closed 16 years ago

Files saved in a shared directory are not shared

Categories

(Toolkit :: Downloads API, defect)

x86
Windows XP
defect
Not set
minor

Tracking

()

RESOLVED DUPLICATE of bug 224692

People

(Reporter: jack, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051115 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051115 Firefox/1.5

I have a single folder on my hard disk which is shared, read-only, on my LAN.  I am using Windows XP Home Edition, so there is no detailed file sharing properties interface (that's an extra $100 . . .).  This folder is my default dowload directory.  When I save a file into this folder, it is not shared the same as the parent folder.  so when someone wants to copy a file from my shared directory, they get a list of files, but anything that was saved there from firefox can't be copied.

The workaround is to (using windows explorer) to move the file out of the shared directory and then move the file back into the shared directory, or make a copy of the file in the same folder, delete the original, and fix the name of the copy.
I would guess that Windows XP Pro has an easier workaround in the properties somewhere.

Reproducible: Always

Steps to Reproduce:
1. In windows xp home edition, create a folder
2. designate this folder as shared on the network (properties, sharing, "share this folder on the network")
3. in firefox, arrange for your downloads to be saved to the new shared folder; It does not appear to matter whether it is via the "ask me every time" method or "save all files to this folder";
4. download something
5. From another computer, access the shared directory
6. try to copy the file to this second computer
Actual Results:  
Windows XP error "Cannot copy [filename]

Make sure the disk is not full or write protected and that the file is not currently in use."

I have confirmed that none of those suggestions are accurate, by trying to copy when firefox is not running anymore.

Expected Results:  
I would expect for the file to have the same availability as its parent directory.

I expect that the file properties could be set to match the parent directory's.
Duplicate of bug 300400 -> Core bug 224692?
That definitely describes my problem.  Thanks - I couldn't find it when I was searching.

*** This bug has been marked as a duplicate of 224692 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.