If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

XUL error page allows error message to accept focus

VERIFIED DUPLICATE of bug 257938

Status

()

Firefox
General
--
trivial
VERIFIED DUPLICATE of bug 257938
12 years ago
12 years ago

People

(Reporter: Doug, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

When the XUL error page loads, nothing is focused. Hit Tab and the error message is focused, for no good reason: It doesn't do anything when you click on it or hit enter, so why is it focused?

Reproducible: Always

Steps to Reproduce:
(Reporter)

Comment 1

12 years ago
Related to, but not the same as, Bug 301471.

Comment 2

12 years ago
Created attachment 203884 [details]
testcase

Comment 3

12 years ago
The "overflow: auto;" in netError.css causes the paragraph to be tabbable.  The paragraph was given "overflow: auto;" by the fix for bug 309606, "Too long string in file not found xul error page isn't wrapped".

Should elements with "overflow: auto;" that don't have scrollbars be tabbable?  That seems to be under debate in bug 257938 and bug 296259.

Btw, networking error pages are now mostly XHTML, not XUL.

*** This bug has been marked as a duplicate of 257938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.