Closed Bug 31755 Opened 20 years ago Closed 20 years ago

please remove hard code string from nsFileSpecWithUIImpl::SetFileWidgetFilterList

Categories

(Core :: XUL, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 31382

People

(Reporter: ftang, Assigned: mikepinkerton)

References

()

Details

In  widget/src/xpwidgets/nsFileSpecWithUIImpl.cpp
nsFileSpecWithUIImpl::SetFileWidgetFilterList
There are a lot of hard coded string for human readable language. These text 
should be stored into property files so we can localize them.

173   if (mask & eAllReadable)
174   {
175     *nextTitle++ = "All Readable Files";
176     *nextFilter++ = "*.eml; *.txt; *.htm; *.html; *.xml; *.gif; *.jpg; 
*.jpeg; *.png";
177   }
178   if (mask & eMailFiles)
179   {
180     *nextTitle++ = "Mail Files (*.eml)";
181     *nextFilter++ = "*.eml";
182   }
183   if (mask & eHTMLFiles)
184   {
185     *nextTitle++ = "HTML Files (*.htm; *.html)";
186     *nextFilter++ = "*.htm; *.html";
187   }
188   if (mask & eXMLFiles)
189   {
190     *nextTitle++ = "XML Files (*.xml)";
191     *nextFilter++ =  "*.xml";
192   }
193   if (mask & eImageFiles)
194   {
195     *nextTitle++ = "Image Files (*.gif; *.jpg; *.jpeg; *.png)";
196     *nextFilter++ = "*.gif; *.jpg; *.jpeg; *.png";
197   }
198   if (mask & eTextFiles)
199   {
200     *nextTitle++ = "Text Files (*.txt)";
201     *nextFilter++ = "*.txt";
202   }
203   if (mask & eExtraFilter)
204   {
205     *nextTitle++ = inExtraFilterTitle;
206     *nextFilter++ = inExtraFilter;
207   }
208   if (mask & eAllFiles)
209   {
210     *nextTitle++ = "All Files";
211     *nextFilter++ = "*.*";
212   }
213
Blocks: 31288
reassigning to pinkerton as p3 for m15
Assignee: trudelle → pinkerton
Summary: please remove hard code string from nsFileSpecWithUIImpl::SetFileWidgetFilterList → please remove hard code string from nsFileSpecWithUIImpl::SetFileWidgetFilterList
Target Milestone: M15
It is a duplicate of bug 31382.


*** This bug has been marked as a duplicate of 31382 ***
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → DUPLICATE
verified duplicate
Status: RESOLVED → VERIFIED
Blocks: 12394
You need to log in before you can comment on or make changes to this bug.