attachment name encode is illegal and recognized as *.DAT by Outlook Express

RESOLVED DUPLICATE of bug 309566

Status

defect
RESOLVED DUPLICATE of bug 309566
14 years ago
13 years ago

People

(Reporter: ypwang, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Reporter

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; zh-CN; rv:1.7.12) Gecko/20050919 Firefox/1.0.7

Version: 1.5 rc1 Simplified Chinese
attachement encoded string: 
Content-Type: application/octet-stream;
 name*0*=GB2312''VOIP%B9%D8%BC%FC%BC%BC%CA%F5%B9%BA%C2%F2%BD%A8%D2%E9%B1%A8
 name*1*=%B8%E6%BC%D3.ppt
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename*0*=GB2312''VOIP%B9%D8%BC%FC%BC%BC%CA%F5%B9%BA%C2%F2%BD%A8%D2%E9
 filename*1*=%B1%A8%B8%E6%BC%D3.ppt

message composed by TB 1.0.7 with English Version is just OK in Outlook Express
TB 1.0.7 encoded string: 
Content-Type: application/octet-stream;
 name="=?GB2312?B?Vk9JULnYvPy8vMr1ubrC8r2o0umxqLjmvNMucHB0?="
Content-Transfer-Encoding: base64



Reproducible: Always

Steps to Reproduce:
1. choose a file with local-language file name
2. add it to the current composing message
3. send it and received by Outlook Express

Actual Results:  
see the attachment in Outlook Express, it appears "ATD000XXX.DAT"

Expected Results:  
it should apprear the original local-language file name

Comment 1

14 years ago
How is it displayed by Thunderbird? I believe this is simply a bug in Outlook Express. You can turn off parm folding in thunderbird with the hidden pref:

user_pref("mail.strictly_mime.parm_folding", 0); // or 1 works as well, I think

and resend the mail.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Reporter

Comment 2

14 years ago
(In reply to comment #1)
> How is it displayed by Thunderbird? I believe this is simply a bug in Outlook
  
*it is displayed well by thunderbird.

> Express. You can turn off parm folding in thunderbird with the hidden pref:
> user_pref("mail.strictly_mime.parm_folding", 0); // or 1 works as well, I think
> and resend the mail.

* I have tried, it works well. 
* thanks.

Comment 3

14 years ago
David, it doesn't help to say "there must be a bug in Outlook".

It seems Thunderbird 1.0.x used "0" as default for this pref: "mail.strictly_mime.parm_folding".

In Thunderbird 1.5 (1.8 Branch) is this default:
pref("mail.strictly_mime.parm_folding", 2);  // 0/1 (RFC 2047), 2(RFC 2231)

http://www.faqs.org/rfcs/rfc2047.html
http://www.faqs.org/rfcs/rfc2231.html

So Thunderbird switched from RFC2047 to RFC2231 in attachment names handling. The problem may be Outlook, which doesn't support RFC 2231. But there are problems in some german webmail interfaces and in other mail clients like Pegasus, Revolver, Outlook Express, ...

Opera 8.5 hat no problems with pref("mail.strictly_mime.parm_folding", 2);
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---

*** This bug has been marked as a duplicate of 309566 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.