Scroll causes addr line to mimic other line's addressee

VERIFIED FIXED

Status

MailNews Core
Composition
P3
normal
VERIFIED FIXED
18 years ago
9 years ago

People

(Reporter: laurel, Assigned: David Hyatt)

Tracking

({pp})

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

18 years ago
Using 2000-03-13-18-nb1b commercial build NT 4.0

When entering several addressees in message compose, scrolling upward to the
first addressee line will cause address line(s) to display another address
line's addressee.

1.  Open compose window.
2.  Type addr1 then Enter.
3.  Type addr2 then Enter.
4.  Type addr3 then Enter.
5.  Scroll upward to top address line.
    Result:  Address lines 2 and 3 now show the same addressee, "addr2". (If
sent, the real, separate addressees are honored.)
(Reporter)

Updated

18 years ago
Keywords: pp
QA Contact: lchiang → laurel
(Reporter)

Comment 1

18 years ago
Additional note:  if each line has different header To: Bcc: CC:, etc. scrolling
doesn't change the header type selection, just the email address as typed in the
address line.

Comment 2

18 years ago

*** This bug has been marked as a duplicate of 31108 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

18 years ago
Closing as duplicate.
Status: RESOLVED → VERIFIED
(Reporter)

Comment 4

18 years ago
Reopening this bug to stand as separate issue from bug #31108 per request from
jar in bug #31108.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 5

18 years ago
hyatt: this only happens if there are exactly 3 addresses in the tree.  any clue 
what is magical about "3"?
(Reporter)

Comment 6

18 years ago
This also happens if you add another couple addressees after picking up from
step5.  Each time you add a few addressees and scroll upward this happens. 
Seems to clear on scrolling downward from the first line. Eeek. I hate these
kinds of bugs.
(Reporter)

Comment 7

18 years ago
*** Bug 33041 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
hyatt: I have no idea what to do with this.  With changes to trees and edit 
controls, I'm going to pass this off to you.  Mike, does the work you're doing 
invalidate this bug?
Assignee: buster → hyatt
Status: REOPENED → NEW
I haven't seen this problem for a while now. Laurel, can you check if you are 
still able to reproduce this problem. Thanks
(Reporter)

Comment 10

18 years ago
Still happens using 2000-05-18-08m16 commercial build.
(Reporter)

Comment 11

18 years ago
*** Bug 41593 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 12

18 years ago
nominating for beta2 
Keywords: nsbeta2

Comment 13

18 years ago
Putting on [nsbeta2+] radar for beta2 fix. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 14

18 years ago
fixed.
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 15

18 years ago
OK using 2000-06-20-08 m17 commercial build NT 4.0
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.