Scrolling in Address Widget Changes Display of Addressees

VERIFIED DUPLICATE of bug 31832

Status

MailNews Core
Composition
P3
normal
VERIFIED DUPLICATE of bug 31832
19 years ago
10 years ago

People

(Reporter: sol, Assigned: Jean-Francois Ducarroz)

Tracking

Trunk
x86
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
If you enter exactly 3 email addresses in the addressing widget of the Compose 
window, and then scroll down and up using the widget's scroll bar, the display 
changes the name of the 3rd recipient to be the same as the 2nd recipient. Note, 
however, that when you send the message, the message is correctly sent to 3 
different recipients. Also note that this does not appear to be a problem with 
less than 3 or more than 3 recipients.

Build ID: 2000-03-23-06-nb1b, commercial, on WinNT

Steps to reproduce:

1. Launch Seamonkey

2. Launch Mail (Tasks | Mail)

3. Open a message compose window ("New Msg" on 3-pane toolbar)

4. Address your message to exactly 3 recipients, hitting [return] after entering 
each line
     To: foo@bar.com
     cc: bar@foo.com
     cc: foobar@com.com

5. Scroll up to the top of the recipient list

Expected: Addressee list remains as you entered it

Actual: The name displayed for the 3rd addressee is changed to match that of the 
2nd addressee. In the example above, you see:
     To: foo@bar.com
     cc: bar@foo.com
     cc: bar@foo.com

Note: If you send the message, the message is correctly sent to "foo@bar.com", 
"bar@foo.com" and "foobar@com.com". This appears to be a display problem, not a 
data loss problem.

Comment 1

19 years ago

*** This bug has been marked as a duplicate of 31832 ***
Status: NEW → RESOLVED
Last Resolved: 19 years ago
QA Contact: lchiang → laurel
Resolution: --- → DUPLICATE

Comment 2

19 years ago
Marking verified as a duplicate.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.