Ability to rearrange the order of the folders within an account

NEW
Unassigned

Status

--
enhancement
13 years ago
a month ago

People

(Reporter: reuben-mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051130 Firefox/1.5
Build Identifier: Mozilla Thunderbird version 1.6a1 (20051129)

There appears to be no provision to order the mailbox folders for an account.  At present they are all sorted alphabetically, but often this is sub optimal.  As an example, I may wish to put my most frequently accessed mailboxes directly underneath my Inbox or Trash - not access them via a scrollbar off the bottom of the page.

This RFE is not to do with rearranging the order of the ACCOUNTS, nor the contents of the folders, but the order of the FOLDERS themselves underneath the account.

The workaround is to rename folders to have names start with A, or use odd characters like the ~ symbol.  That's pretty ugly though, it seems pretty wrong that I have to name my busiest folder "ALinux Kernel" to have it alphabetically listed up the top of the list.

A drag-and-drop approach showing the proposed position with a faint line between the two mailboxes would be both intuitive, much like moving folders within other folders which has good drag-and-drop support.  It would also be logical to include a "Move Up" and "Move Down" entry when right clicking on each folder.



Reproducible: Always

Actual Results:  
Unable to rearrange the order

Expected Results:  
Custom arrangement of the order of folders

Drag and drop the order of the folders would be ideal.

Comment 1

13 years ago
Seamonkey bug 193314.  Bug 245672 was a TB bug but duped against the Seamonkey bug; maybe that's correct and this is actually a core bug, or maybe it's strictly front-end.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

13 years ago
I would like to see this capability for all accounts -- mail, news, and RSS/blog.
But perhaps the different types need separate fixes and should be separate bugs.

The present inability to change the order in which newsgroups are displayed within a news account (which seems to be fixed as the order in which you subscribed to them) by dragging them within the folder pane is certainly just a front-end problem, because I've found this workaround: exit Mozilla (or Thunderbird), then text-edit the file profile_directory/News/news_server_name.rc, which appears to be nothing more than a trn-style .newsrc, and move the newsgroup lines to the order in which you want them displayed.
QA Contact: front-end

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 193314

Comment 4

10 years ago
Request reopening as Thunderbird/Mail_News Core.  The workaround has stopped working; newsgroups I added recently aren't reflected in news_server_name.rc.

Comment 5

10 years ago
the original bug is about mail.  We don't reopen bugs because workarounds don't work. :)  however, unduping so it's easier for bug filers to find, and dependent on the core bug.  I didn't check for dupes, so not confirming
Assignee: mscott → nobody
Status: RESOLVED → UNCONFIRMED
Component: Mail Window Front End → Folder and Message Lists
Depends on: 193314
QA Contact: front-end → folders-message-lists
Resolution: DUPLICATE → ---
No newer dupes -> Confirming.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 486155

Updated

9 months ago
Duplicate of this bug: 1433928

Updated

a month ago
Duplicate of this bug: 845548
You need to log in before you can comment on or make changes to this bug.