Closed Bug 318594 Opened 16 years ago Closed 16 years ago

clicking twice on folder in bookmark toolbar crashes Firefox 1.5

Categories

(Firefox :: Bookmarks & History, defect)

PowerPC
macOS
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 298502

People

(Reporter: n0zp4m93492y86, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

Firefox 1.5 crashes reproducibly when I open a folder in the bookmark toolbar twice. Opening the folder once does work, opening it for the second time will show a blank folder menu and Firefox will hang.
Firefox 1.0.7 on the same machine does not exhibit this bug.


Reproducible: Always

Steps to Reproduce:
1. start Firefox 1.5
2. create a folder in the bookmark bar, in case there is none already
3. click on a folder in bookmark bar
4. close the folder menu just openend
5. click on the same folder again

Actual Results:  
Firefox shows the bookmark folder menu, but it appears blank, and Firefox hangs indefinitely (Mac OS X shows the "spinning beachball" cursor).


Expected Results:  
Firefox should open the bookmark folder menu each time you click on the bookmark toolbar to open it, it should not hang when you do this for the second time.


Mac OS X 10.2.8
Dual-USB 14" iBook
G3 CPU, 800 MHz
384 MB RAM
ATI Radeon 7500 Mobility, 32 MB VRAM
combo drive
30 GB HD
add to step 2: "...and drag a couple of bookmarks onto the created folder"

*** This bug has been marked as a duplicate of 312111 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

*** This bug has been marked as a duplicate of 298502 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.