bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

can not uninstall extension - disabled buttons

VERIFIED DUPLICATE of bug 319022

Status

()

Toolkit
Add-ons Manager
--
minor
VERIFIED DUPLICATE of bug 319022
13 years ago
10 years ago

People

(Reporter: Damian Szczepanik, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; pl; rv:1.8) Gecko/20051111 Firefox/1.5

I can't uninstall extension "blanklast", because the button uninstall is disabled
I have double "wrong" items of this extension and it happend when i migrated to Firefox 1.5

I also found, that copy of this extnesion is in staged-xpis directory, but even when I remove it - still nothing
Removing entries (RDF:Description and RDF:li) from file Extensions.rdf doesn't fix my problem
Uninstall third extension and install again is not good idea - i cant' find way to remove that two phantom-extension

I have no problem with blanklast - it works fine but two identical phantom makes me crazy;)

Reproducible: Always

Actual Results:  
see shreenshot

Expected Results:  
set button uninstall enabled (?)

any idea how to remove it - even manually, deleting or changing some files...
(Reporter)

Comment 1

13 years ago
Created attachment 204890 [details]
screenshot, buttons are not enabled
See https://bugzilla.mozilla.org/show_bug.cgi?id=317193#c2
It's about attaching the install.rdf of each extension and extensions.rdf.
(Reporter)

Comment 3

13 years ago
hmmm, I've never try to uninstall this extension before (first time, when I saw double entries at Firefox 1.5) so the reason can be the same, but scenario.

I can't also attach this extension as bug 318926 comment 2 because finally i haven't got any entry about blanklast in Extensions.rdf ;(
(Reporter)

Comment 4

13 years ago
instruction at http://kb.mozillazine.org/Uninstalling_extensions also donesn't help me - buttons are still disabled
Damian, can you please attach your extensions.rdf to this bug? It is located in your profile directory.
http://www.mozilla.org/support/firefox/profile
(Reporter)

Comment 6

13 years ago
Created attachment 206479 [details]
extensions.rdf

before you open this file - I have to add something important

since that time I've tried to uninstall or remove it manually (as i mantioned above) so today I have one working BlankLast extension and one (not two) disabled. File you're asking looks good, because I uninstalled this extension, remove entries and install again.

Description (font is red) next to disabled extension says (I have polish version, so I'm not sure about technical meaning of this text):
Firefox is checking updates about ability of compatibility for BlankLast entity.

If you need more files, let me know
That is the 1.0 Extensions.rdf from your profile's extensions directory... the one that is for 1.5 is extensions.rdf (notice the lower case e) inside of your profile's directory. Could you please attach that one?
(Reporter)

Comment 8

13 years ago
Created attachment 206488 [details]
extensions.rdf from profile directory

This one I haven't seen before, so I didn't manually edit it

see at line 662 - this text I see in extension manager
Note: this looks like it was caused by closing the Extension Manager before the extension had completely installed and it was being checked for a compatibility update.
Damian - if you delete the extensions.rdf in your profile directory (it will be regenerated) it should fix this issue. Chances are this bug will be fixed when one of the other bugs is fixed for closing the extension or theme manager before the install has completed.
(Reporter)

Comment 11

13 years ago
So, what you suggest is to delete one file? Ok, I can do this, but I wanted to leave it as long as it is possible to give you good environment to test this bug, because as I wrote - I can't reproduce it. That means that after this operation you will not be able to check anything in future (even if you have no plans today)

You sure, that that this staate (with bug) will not be helpful in future?
If not, I try to delete it in verify, but I can work with this bug, because it dosn't disturb mi ;-)

What you said is good solution for effect but not for reason. Think about it
(In reply to comment #11)
> So, what you suggest is to delete one file? Ok, I can do this, but I wanted to
> leave it as long as it is possible to give you good environment to test this
> bug, because as I wrote - I can't reproduce it. That means that after this
> operation you will not be able to check anything in future (even if you have no
> plans today)
> 
> You sure, that that this staate (with bug) will not be helpful in future?
> If not, I try to delete it in verify, but I can work with this bug, because it
> dosn't disturb mi ;-)
> 
> What you said is good solution for effect but not for reason. Think about it
I have thought about it and already know a couple of the causes for this bug. Your environment only provides the state after the bug has occurred and hence provides no value at this time so it is safe to delete the file as it relates to this bug. Since there is no way to reproduce and there are known causes of this symptom with only a small chance of there being causes that are not known in this instance chances are what caused the symptom for you will have to be fixed in one of the bugs with the same symptom. I also have your extensions.rdf file which is the only file required for me to replicate the symptom you are experiencing.
(Reporter)

Comment 13

13 years ago
Created attachment 209489 [details]
extension.rdf after delete and restart firefox

so finally i can say, that your advice works fine ;-)

I'd like to add, that I lost some information: order of extension (I sorted them) and information which of them should not be inited, but it took me two minutes to recovery this information

I add new extension.rdf if it will be helpful in the future and for me - the bug is fixed, so please decide how resolve it and change resolution
Let me know if I can help you, that is all for me role, I can't verify it because as i wrote I can't reproduce it in future ;|

*** This bug has been marked as a duplicate of 319022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 15

13 years ago
it is duplicate and it is also resoled
I verified this bug
Status: RESOLVED → VERIFIED
(Reporter)

Comment 16

12 years ago
today I got similar problem, the same entity (but only single):

  <RDF:Description RDF:about="C:\Documents and Settings\Damian Szczepanik\Dane aplikacji\Mozilla\Firefox\Profiles\3bzx3c4a.damian\extensions\staged-xpis\{333670ee-d9e7-47be-83aa-d67bba8d4266}\tmp-5185.xpi"
                   NS1:name="Paste and Go"
                   NS1:iconURL="chrome://mozapps/skin/xpinstall/xpinstallItemGeneric.png"
                   NS1:downloadURL="C:\Documents and Settings\Damian Szczepanik\Dane aplikacji\Mozilla\Firefox\Profiles\3bzx3c4a.damian\extensions\staged-xpis\{333670ee-d9e7-47be-83aa-d67bba8d4266}\tmp-5185.xpi"
                   NS1:version="0.4.3"
                   NS1:incompatibleUpdate="true"
                   NS1:description="Program Firefox sprawdza dostÄ&#8482;pnoÅ&#8250;Ä&#8225; aktualizacji dotyczÄ&#8230;cych kompatybilnoÅ&#8250;ci dla elementu Paste and Go.">
    <NS1:type NC:parseType="Integer">2</NS1:type>
  </RDF:Description>

in extensions.rdf file

And as Rober said (comment 9) it is possible, that this extension was not installed properly. I had english version and then installed polish one. What was interesting - firefox told me, that version is not compatiblity (FF 1.5.0.3) and will not be installed, however I saw polish labels, so everything went fine.
Or not, because today I saw entity and buttons was disabled, so I manually remove them. English and polish version of extension was equal.
When Firefox was looking for new updates, CPU went up to 100%, so I killed proces, and mayby then installation crashed (?). I tried to reproduce it in clean profile - no way :/

Install manager should be improved, because end-user can not remove (uninstall) extension and do it manually is not good way
Status: VERIFIED → UNCONFIRMED
Resolution: DUPLICATE → ---
I'm not sure why you reopened this bug. The other bug is fixed for Firefox 2.0 and on the Trunk which will next become 3.0 yet you are testing with 1.5.0.3 which doesn't have the fix. If you can't reproduce with a latest nightly that isn't a 1.5.0.x nightly then re-mark this bug as duplicate of bug 319022.
(Reporter)

Comment 18

12 years ago
If version 1.5.0.3 does not include changes, that have been fixed before, you must right

*** This bug has been marked as a duplicate of 319022 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago12 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

12 years ago
Status: RESOLVED → VERIFIED
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.