Last Comment Bug 319022 - extensionlist shows XPI as xxxxxxxx.xpi without any usefulness
: extensionlist shows XPI as xxxxxxxx.xpi without any usefulness
Status: RESOLVED FIXED
: fixed1.8.1
Product: Toolkit
Classification: Components
Component: Add-ons Manager (show other bugs)
: 1.8.0 Branch
: x86 Windows XP
: -- normal (vote)
: mozilla1.8.1alpha1
Assigned To: Robert Strong [:rstrong] (use needinfo to contact me)
:
Mentors:
: 260276 266117 318926 325423 336697 340230 346309 346465 (view as bug list)
Depends on:
Blocks: 326722
  Show dependency treegraph
 
Reported: 2005-12-04 04:09 PST by Sebastian
Modified: 2008-07-31 04:30 PDT (History)
13 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments
mysterious ... (22.07 KB, image/gif)
2005-12-04 04:09 PST, Sebastian
no flags Details
patch (2.23 KB, patch)
2006-02-10 13:34 PST, Robert Strong [:rstrong] (use needinfo to contact me)
mconnor: review+
robert.strong.bugs: approval‑branch‑1.8.1+
Details | Diff | Review

Description Sebastian 2005-12-04 04:09:02 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8) Gecko/20051111 Firefox/1.5

I updated to FF 1.5. Many extensions were disabled while installing. Some could be updated automatically. On (here SessionSaver2) has to be updated manually from another website than mozilla.extensions. Now i have two rows in the extension manager. First the normal extension with full functionality 8works fine) and second a row with "sessionsaver-02-dev.xpi", that does nothing (right-click-menu is greyed-out) ... seems to be an error in extension handling.

Reproducible: Always
Comment 1 Sebastian 2005-12-04 04:09:42 PST
Created attachment 204943 [details]
mysterious ...
Comment 2 Ria Klaassen (not reading all bugmail) 2005-12-04 06:20:27 PST
In case anyone might want to study them, please attach the extensions.rdf in your profile and the install.rdf's of every extension in the folder extensions before you restore your profile.
Like described on the bottom of this bug: Bug 317193.
Comment 3 Robert Strong [:rstrong] (use needinfo to contact me) 2006-01-06 01:35:16 PST
This happens when an extension doesn't complete an install and there are several bugs open to fix the cause of this symptom. To fix this on your system you can delete the extensions.rdf file in your profile directory and it will be recreated.
http://www.mozilla.org/support/firefox/profile

If it fixes it this bug will be fixed in another bug. If it does not then there is another bug this bug is masking and we can take this further. Please post back whether this fixes it or not.
Comment 4 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-10 13:34:25 PST
Created attachment 211422 [details] [diff] [review]
patch

We continue the download of an extension when the extension manager ui is closed but we only remove the download item in the rdf from extensions.js. This move the call to INSTALL_DONE in nsExtensionManager.js.in.
Comment 5 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-10 13:35:22 PST
*** Bug 318926 has been marked as a duplicate of this bug. ***
Comment 6 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-10 13:37:10 PST
*** Bug 260276 has been marked as a duplicate of this bug. ***
Comment 7 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-10 13:57:06 PST
Mel, you brought up this bug to me once before and if you have the time I'd appreciate your help with verifying this is working as expected, etc. when it is patched.
Comment 8 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-10 17:34:53 PST
checked in to trunk
Comment 9 Mel Reyes 2006-02-10 23:07:29 PST
weird, I didn't get your email, but happened to come across this on mozillazine trunk list.

I'll do some testing on an older computer where I think I can dupe this.  I'm "assuming" this will only help this from happening in the future, right?  Which bugs are related to this one to resolve existing (as I like to call them) "ghost" entries?
Comment 10 mdew 2006-02-11 01:22:11 PST
this is a very annoying bug in 1.5, any chance of this being reviewed for branch?
Comment 11 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-11 12:16:34 PST
Mel, bug 326722 which this bug blocks is to take care of the existing ghost entries. This appears to have fixed the application quit bug when installing an extension in that I was only able to get it to show the cancel download dialog one time and when I clicked cancel the entry was removed from the Extension Manager ui. It also now successfully completes installations if you close the Extension Manager ui and leave it closed while an install is being performed similar to how the Download Manager will complete a download.

mdew, I will land this on the MOZILLA_1_8_BRANCH (e.g. Firefox 2.0) after I get verification from others that it is working as expected without any serious regressions. As for the MOZILLA_1_8_0_BRANCH (e.g. Firefox 1.5.x.x) I doubt it. I would want bug 326722 which will be a more complicated patch to land as well otherwise we would have 3 different cases with release builds as follows instead of just cases 1 and 3.
1) 1.5 ghost entries and can reproduce this bug
2) 1.5.0.2 ghost entries and can't reproduce this bug
3) 2.0 no ghost entries and can't reproduce this bug
Comment 12 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-11 13:40:57 PST
I did some further testing today using the different versions of http://spellbound.sourceforge.net/install since it installs multiple extensions during a single install and all worked as expected. When installing / upgrading to an incompatible extension and closing the EM ui the incompatible alert is displayed. When exiting when installing / upgrading and quiting the application if you click cancel downloads the extensions are not left behind in the extensions datasource and when you click don't exit the extensions are installed properly.

Everything looks good to me but I suspect there are still a couple of edgecases lying around. Confirmation from others on this bug would be appreciated.
Comment 13 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-11 15:52:40 PST
One way to still get the appearance of a "ghost" entry is to start two installs of themes - possibly extensions as well - separately which is bug 251519. The entry in the Theme Manager that finishes last will look the same as a "ghost" entry when the first install completes but it will continue the install and complete successfully which removes the "ghost" entry. So, bug 251519 appears to now be a visual glitch which will correct itself.
Comment 14 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-11 15:59:39 PST
*** Bug 266117 has been marked as a duplicate of this bug. ***
Comment 15 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-17 10:53:46 PST
Checked in on MOZILLA_1_8_BRANCH
Comment 16 Robert Strong [:rstrong] (use needinfo to contact me) 2006-02-19 21:54:04 PST
*** Bug 316038 has been marked as a duplicate of this bug. ***
Comment 17 Robert Strong [:rstrong] (use needinfo to contact me) 2006-04-13 10:59:45 PDT
*** Bug 325423 has been marked as a duplicate of this bug. ***
Comment 18 Robert Strong [:rstrong] (use needinfo to contact me) 2006-05-04 23:53:28 PDT
*** Bug 336697 has been marked as a duplicate of this bug. ***
Comment 19 Damian Szczepanik 2006-05-12 09:15:13 PDT
*** Bug 318926 has been marked as a duplicate of this bug. ***
Comment 20 Robert Strong [:rstrong] (use needinfo to contact me) 2006-06-03 10:04:42 PDT
*** Bug 340230 has been marked as a duplicate of this bug. ***
Comment 21 Robert Strong [:rstrong] (use needinfo to contact me) 2006-07-28 13:47:03 PDT
*** Bug 346309 has been marked as a duplicate of this bug. ***
Comment 22 Robert Strong [:rstrong] (use needinfo to contact me) 2006-07-29 18:46:58 PDT
*** Bug 346465 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.