Closed Bug 319032 Opened 16 years ago Closed 16 years ago

delete attachment and detach attachment don't really remove the attachment

Categories

(Thunderbird :: General, defect)

x86
Windows XP
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 286888

People

(Reporter: n_biber, Assigned: mscott)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: thunderbird version 1.5 (20051025)

Delete attachment and detach attachment only cause attachment to appear to be deleted, but the size of the inbox or outbox file remains the same. The attachment still appears in the file's source.

Reproducible: Always

Steps to Reproduce:
1.select message
2.right click on attachments
3.select delete, detach, delete all or detach all
4.observe inbox/sent file size

Actual Results:  
thunderbird showed the expected message size after deletion, but inbox/sent file remained the same size

Expected Results:  
also delete the attachment from the inbox/sent file
You need to compact the folder after delete/detach. There are bugs for more automatic compact, e.g. bug 286888 or bug 197605.
Yes, there is no point having a bug for this specific case of "compact must be done manually". Reporter, suggest you go and vote for bug 286888, which would have the compacting of space done automatically.

Actually it is quite a difficult problem, related to the design of the mail store - which is in turn a kind of standard - and the fact it is plain text.

You will find most database systems - such as mail - do not actually delete anything immediately. At most they will blank out the space and mark some area as free for the next sensible time to compact.

Arguably I guess that TBird could blank out the deleted mail for security, but that is probably not possible with the current design which *never* actually modifies messages - only adds new ones (that is how the attachment delete was implemented).


*** This bug has been marked as a duplicate of 286888 ***
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.