Thunderbird does not give warning for Empty Trash

RESOLVED WORKSFORME

Status

--
enhancement
RESOLVED WORKSFORME
13 years ago
6 years ago

People

(Reporter: firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

No warning is given on Empty Trash thus wiping out whole Trash at once even when this is hit by system slow reply or by chance

Very unfortunate - I have just wiped out about two years of messages this way!!!



Reproducible: Always

Steps to Reproduce:
1. Go to File->Empty Trash
2. You are ****.
3.

Actual Results:  
Everything is wiped

Expected Results:  
Warning should be given prior to wiping out files
(Reporter)

Comment 1

13 years ago
Version 1.0.7 Linux
->new 
Thunderbird version of bug 179891. It's not only the file menu BTW.

Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Thunderbird does not give warning when Empty Trash is chosen from File menu → Thunderbird does not give warning for Empty Trash

Updated

13 years ago
Severity: critical → enhancement

Comment 3

13 years ago
*** Bug 330865 has been marked as a duplicate of this bug. ***
Assignee: mscott → nobody

Comment 4

6 years ago
the trend in recent years is for "undo" to be the data recovery of choice. And we have in the past wontfix bugs that request relief for cases of "operator error".

But if that's not appropriate here, then this should be changed from ENH to some reasonably high severity.
Component: General → Mail Window Front End
Flags: needinfo?(bwinton)
Whiteboard: [wontfix?]

Comment 5

6 years ago
that said, it seems we have mail.emptyTrash.dontAskAgain which is false by default, and forces the prompt. I don't know when it was implemented
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Flags: needinfo?(bwinton)
Resolution: --- → WORKSFORME
Whiteboard: [wontfix?]
You need to log in before you can comment on or make changes to this bug.