Articles printed on nytimes.com use a tiny font

RESOLVED WONTFIX

Status

()

Core
Printing: Output
RESOLVED WONTFIX
13 years ago
10 years ago

People

(Reporter: Matthew Gertner, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When I print the "printer-friendly" version of nytimes.com articles, they are rendered using a tiny font (the same occurs with the print preview). After some fiddling around, I discovered that the articles print correctly when the document footer (the div tag with the "footer" id) is removed, or if the corresponding style rules are removed from the associated CSS file. Since the articles print correctly from IE, I believe this is due to some sort of CSS bug, although I wasn't able to narrow down the problem.

Reproducible: Always

Steps to Reproduce:
1. Print up any nytimes.com article.
2. Select the printer-friendly version.
3. Print it.

Actual Results:  
Font is much smaller than intended.

Expected Results:  
Use of correct font size.
Not a CSSOM issue (and probably invalid).  The footer has a lot of text and doesn't allow line-breaks, so if you have the "shrink to fit page width" preference set (and only then) the font size will come out rather small -- small enough to fit the entire footer on the page.  If the preference is not set, the font will be reasonable and the footer will be cut off.

I really don't see what else could be done here given the markup on the page and that preference set (short of ignoring the nowrap style on the footer, perhaps, but it's not obvious how we're supposed to guess to do that).
Assignee: general → printing
Component: DOM: CSSOM → Printing
QA Contact: ian
(Reporter)

Comment 2

13 years ago
I see. On my machine, I don't see an option to change the "shrink to fit" setting (which is the default) unless I do a print preview. Maybe this shouldn't be the default setting? Or perhaps the right action item is to contact nytimes.com and tell them that their printer-friendly pages don't print correctly from Firefox when the default settings are used?
(Reporter)

Comment 3

13 years ago
Okay, I found the setting under Page Setup. I still think that it would be nice if pages like this were to print in a more readable manner using the default settings, but I'm not sure what the best approach would be to achieve this.
Yeah, in _most_ cases this setting gives slightly better default layout...

And yes, if you would be willing to contact nytimes that would be a good idea.
(Reporter)

Comment 5

13 years ago
(In reply to comment #4)
> And yes, if you would be willing to contact nytimes that would be a good idea.

Done. If I get a response, I'll post an update here.
(Reporter)

Comment 6

13 years ago
As far as I see, nytimes.com has fixed the problem. The footer is now squeezed by the CSS stylesheet without affecting the rest of the text.
Matthew, thanks for mailing them!  Marking wontfix, since I still don't see how we can render the markup they used to have well while keeping the shrink-to-fit default we have (which we do want).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX

Comment 8

13 years ago
*** Bug 286026 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.