partial areas of the web page do not print as they should pre{white-space:normal;} (Microsoft Knowledgebase)

RESOLVED INCOMPLETE

Status

RESOLVED INCOMPLETE
13 years ago
4 years ago

People

(Reporter: jaltamirano1, Assigned: mozbugs)

Tracking

({testcase})

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8) Gecko/20051111 Firefox/1.5

A CSS preformatted tag (<pre class=in_text>), when sent to the network printer prints the text in a single wrapped line....thus distorting the expected format.

Reproducible: Always

Steps to Reproduce:
1.navigate to http://support.microsoft.com/default.aspx?scid=kb;en-us;249694
2.click on the "print" icon located on the right hand side of the web page itself.
3.Select your printer.
4.See section mentioning DHCP found on first page.

Actual Results:  
4.On printed page see section mentioning DHCP found on first page.

You will see the suppossedly five lines printed in a single wrapped line.

Expected Results:  
IE prints it appropriately, 5 lines.

Comment 1

13 years ago
Related to/duplicate of bug 266152?
(Assignee)

Comment 2

13 years ago
It looks like the original page reported (http://support.microsoft.com/default.aspx?scid=kb;en-us;249694) has been updated since this bug was reported and no longer shows the problem. There is no <pre class=in_text> section and DHCP is not mentioned anywhere in the page any more. According to the page it had its "Last Review" on "February 17, 2006", this bug was originally reported 2005-12-07.

Had a look around the MS Knowledgebase and the following page (http://support.microsoft.com/kb/298367/) is showing what appears to be the same problem, again with a multi-line section of text set to <pre class=in_text>. The section titled "Understanding DHCP Event IDs" is a neat table on screen, but shows up as one continuous wrapped line when you print.

Suggest updating the bug's URL field with the new URL below:
http://support.microsoft.com/kb/298367/

I'm seeing the problem in both Firefox 1.0.7 and Firefox 1.5.0.1 on Win XP SP1, you don't actually need to click the "Print this page" icon on the right hand side of the page, the problem shows up if you print using Firefox's standard print icon, and if you use Firefox's Print Preview.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.7.12) Gecko/20050919 Firefox/1.0.7
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

Creating test case.
(Assignee)

Comment 3

13 years ago
Created attachment 214623 [details]
Minimal test case

Test case attached.

It all seems to boil down to the following snippet of CSS buried deep inside one of MS's stylesheets:

@media print{pre{white-space:normal;}}


According to http://www.w3.org/TR/REC-CSS2/text.html#white-space-prop with "white-space: pre" set:

"prevents user agents from collapsing sequences of whitespace. Lines are only broken at newlines in the source"

but with "white-space: normal" set:

"This value directs user agents to collapse sequences of whitespace, and break lines as necessary to fill line boxes."


So as the style sheet sets PRE to "white-space:normal" then sequences of whitespace should collapse, lines should be broken where necessary, and newlines in the source are ignored.

From the way I read the spec it looks like Firefox is doing exactly the right thing here, and its Microsoft's style sheet at http://support.microsoft.com/common/css/default/default.css?3 that is at fault here. Possible candidate for tech evangelism with Microsoft? (I'm pretty sure their knowledgebase people have responded to similar evangelism requests in the past)


For what it's worth Opera 5.1 does exactly the same as Firefox here.
(Assignee)

Comment 4

13 years ago
s/Opera 5.1/Opera 8.51/
(Assignee)

Comment 5

13 years ago
Setting "testcase" keyword, updating URL field as per comment 2, confirming bug, re-assigning to Tech Evangelism and adding "Microsoft Knowledgebase" to title to make this easier to search for.

This is very similar to a previous bug 255117, but that bug dealt with pre{white-space:normal;} in the stylesheet for screen display and has now been fixed by Microsoft, this bug concerns the problems with the print stylesheet.
Assignee: nobody → english-us
Blocks: 114158
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Keywords: testcase
Product: Firefox → Tech Evangelism
QA Contact: general → english-us
Summary: partial areas of the web page do not print as they should (ascii TEXT area) → partial areas of the web page do not print as they should pre{white-space:normal;} (Microsoft Knowledgebase)
(Assignee)

Comment 6

13 years ago
Assigning bug to myself.
Have contacted Microsoft to inform them via the contact links at http://support.microsoft.com/contactussupport/?ws=support using a modified version of the standard site evangelism letter with a brief discussion of the problem in.

Status: NEW → ASSIGNED
(Assignee)

Updated

13 years ago
Assignee: english-us → mozbugs
Status: ASSIGNED → NEW
(Assignee)

Comment 7

13 years ago
Have received what looks like a generic automated reply from Microsoft. The subject line contains what looks like a reference number for my contact in the subject line, RTCProd=011-580-959.

Will wait to see what happens further from this.
Status: NEW → ASSIGNED
(Assignee)

Comment 8

13 years ago
No reply from Microsoft nearly 2 months later, and the knowledgebase website still has the same problems with printed pages.

Have resubmitted this to MS via the Contact US/Support page (URL above) and filled the forms in slightly differently to see if it makes it more likely to reach the right people.

Comment 9

8 years ago
INCOMPLETE due to lack of activity since the end of 2009.

If someone is willing to investigate the issues raised in this bug to determine whether they still exist, *and* work with the site in question to fix any existing issues, please feel free to re-open and assign to yourself.

Sorry for the bugspam; filter on "NO MORE PRE-2010 TE BUGS" to remove.
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.