bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

There's no progress indicator while Thunderbird is checking for junk mail

RESOLVED DUPLICATE of bug 61139

Status

Thunderbird
Mail Window Front End
--
minor
RESOLVED DUPLICATE of bug 61139
13 years ago
11 years ago

People

(Reporter: Guy Harris, Assigned: Scott MacGregor)

Tracking

PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/416.11 (KHTML, like Gecko) Safari/416.12
Build Identifier: version 1.5 (20051025)

Thanks, I think, to the Sober worm (and to my e-mail address being spread far and wide on USENET and so on), I'm getting a *LOT* of mail lately that Thunderbird is classifying as junk; when I read my mail after waking up, I can easily have several hundred junk messages.

While it's downloading the mail, the throbber is active, the progress bar in the status bar moves, and the count of downloaded messages in the status bar increases.  However, once all the mail has been downloaded, and Thunderbird is processing the messages, marking them as junk, and moving them to the Junk mailbox, there's no indication that this is in progress (other than, perhaps, the item for my mail account in the sidebar not having turned blue yet).

The classification can take 10 seconds or perhaps more if I have a lot of messages to process, so it'd be nice to know that Thunderbird is still working on it, and I know I'm not necessarily hit by 318143 and stuck moving all those bugs to Junk by hand.

Reproducible: Always

Steps to Reproduce:
1. Download a very large number (a few hundred) of messages Thunderbird would classify as junk.

Actual Results:  
There was a period where Thunderbird didn't appear to be doing anything, based on anything obvious in the main window, but where it was doing junk mail testing; after that period, the count of messages in Inbox suddenly dropped and the count of messages in Junk suddenly increased.

Expected Results:  
I expected the throbber to be spinning (this is, after all, a Mac :-)) and, perhaps, to have in the status bar a count of messages processed and a progress bar.
(Reporter)

Updated

13 years ago
Version: unspecified → 1.5
QA Contact: front-end

Comment 1

11 years ago
related to bug 306211?

Comment 2

11 years ago
junk processing dependent on download process, so duping to bug 61139
Severity: normal → minor
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 61139
You need to log in before you can comment on or make changes to this bug.