Adv > Cache: Choose Folder doesn't bring up dialog

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: bugzilla, Assigned: matt)

Tracking

({regression, relnote})

Trunk
regression, relnote

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

19 years ago
found while using the following opt beta branch bits:

linux [2000.03.15.06-nb1b, mozilla]
mac [2000.03.15.05-nb1b, mozilla]
winNT [2000.03.15.06-nb1b, commercial]

1. open Prefs dialog, go to Advanced > Cache category.
2. click the Choose Folder button.

result: no dialog for selecting cache folder appears.
(Reporter)

Comment 1

19 years ago
also get the following in the console when clicking the button:

prefCacheSelectFolder
JavaScript Error: ReferenceError: getFileOrFolderURL is not defined
URL: chrome://pref/content/pref-cache.js
Line number: 7

Keywords: beta1, regression
(Assignee)

Comment 2

19 years ago
this is since alecf changed the function name
on feb28.  It's a one line fix.
Personally i don't think that cache folder is that important
but it is a safe fix.

http://bonsai.mozilla.org/cvsview2.cgi?diff_mode=context&whitespace_mode=show&fi
le=prefutilities.js&root=/cvsroot&subdir=mozilla/xpfe/components/prefwindow/reso
urces/content&command=DIFF_FRAMESET&rev1=1.3&rev2=1.4 
Status: NEW → ASSIGNED

Comment 3

19 years ago
Putting on PDT- radar for beta1.  Will relnote.
Keywords: relnote
Whiteboard: [PDT-]
(Assignee)

Updated

19 years ago
Target Milestone: M15
(Assignee)

Comment 4

19 years ago
*** Bug 23158 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 5

19 years ago
no longer seems a problem. tested with:

linux, opt comm: 2000.03.27.11
macOS, opt comm: 2000.03.27.10
winNT, opt comm: 2000.03.27.09
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

19 years ago
.
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
REOPEN Please
This bug is present in 2000-04-18-05 M15 Windows Talkback build.
(Reporter)

Comment 8

19 years ago
this is no longer a problem in the M16 trunk builds (as of 2000.04.21).
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.