"remaining_time" process_bug.cgi error when changing several bugs at once

RESOLVED DUPLICATE of bug 388149

Status

()

--
minor
RESOLVED DUPLICATE of bug 388149
13 years ago
11 years ago

People

(Reporter: altlist, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.10) Gecko/20050716 Firefox/1.0.6

When you change serveral bugs at once and you've enabled the Time Tracking feature, the "remaining_time" cgi parameter is set to "--do-not-change" by default.  

Process_bug.cgi then complains about a a non-numeric string value when doing a numeric comparison around line 630:

  sub _remove_remaining_time {
      if (UserInGroup(Param('timetrackinggroup'))) {
          if ( defined $cgi->param('remaining_time') 
----->         && $cgi->param('remaining_time') > 0 )


Reproducible: Always

Steps to Reproduce:

Comment 1

13 years ago
I can reproduce on tip too. Note that this error only appears in the error log file, at least when using Apache.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Version: unspecified → 2.20

Updated

13 years ago
Target Milestone: --- → Bugzilla 2.20

Comment 2

13 years ago
Related: bug 143313
Blocks: 271023
Target Milestone: Bugzilla 2.20 → Bugzilla 2.22

Updated

12 years ago
Target Milestone: Bugzilla 2.22 → Bugzilla 3.0

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Target Milestone: Bugzilla 3.0 → ---
Duplicate of bug: 388149
You need to log in before you can comment on or make changes to this bug.