Last Comment Bug 320117 - Syntax Error in chrome://editor/content/EdInsertTOC.js
: Syntax Error in chrome://editor/content/EdInsertTOC.js
Status: RESOLVED FIXED
: fixed1.8.0.2, fixed1.8.1
Product: Thunderbird
Classification: Client Software
Component: Message Compose Window (show other bugs)
: unspecified
: All All
-- normal (vote)
: ---
Assigned To: Ray Booysen
:
:
Mentors:
chrome://editor/content/EdInsertTOC.js
Depends on:
Blocks: 121495
  Show dependency treegraph
 
Reported: 2005-12-13 08:01 PST by Bob Clary [:bc:]
Modified: 2006-03-10 17:02 PST (History)
3 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Patch removes an extra } (1.09 KB, patch)
2005-12-13 08:52 PST, Ray Booysen
mozilla: review+
mscott: approval1.8.0.1+
mscott: approval1.8.1+
Details | Diff | Splinter Review

Description User image Bob Clary [:bc:] 2005-12-13 08:01:17 PST
Thunderbird 1.5 rc2

Error: syntax error
Source File: chrome://editor/content/EdInsertTOC.js
Line: 347, Column: 4
Source Code:
    else {
Comment 1 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-13 08:16:04 PST
Looks like it's caused by:
http://lxr.mozilla.org/seamonkey/source/editor/ui/dialogs/content/EdInsertTOC.js#298
Comment 2 User image Ray Booysen 2005-12-13 08:22:00 PST
I'll take this and submit a patch tonight.
Comment 3 User image Bob Clary [:bc:] 2005-12-13 08:25:12 PST
Ok. we need this for the 1.8 branch as well.
Comment 4 User image Ray Booysen 2005-12-13 08:27:55 PST
Seperate patches for trunk and the 1.8 branch?
Comment 5 User image Bob Clary [:bc:] 2005-12-13 08:34:49 PST
The same patch will probably apply to both. We just need to get approval for branch check in I think.
Comment 6 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-13 08:41:03 PST
Caused by the patch from bug 121495 (revision comment refers to the wrong bug #). Rather unfortunate that it's been this way on the trunk since 2004-04-15.
Comment 7 User image Ray Booysen 2005-12-13 08:52:49 PST
Created attachment 205731 [details] [diff] [review]
Patch removes an extra }

Patch fixes the extra } in the line.
Comment 8 User image Erik Fabert 2005-12-13 10:30:54 PST
Why not use some of the tricks the DOM implementation has learnt over the last few years? Simply setting toc.textContent = "" should do the same as the loop.
Comment 9 User image Ray Booysen 2005-12-13 12:37:46 PST
Thanks, but I'll wait until someone reviews the patch before changing it. :)
Comment 10 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-15 06:19:44 PST
Comment on attachment 205731 [details] [diff] [review]
Patch removes an extra }

A change like this doesn't require super-review. I can check it in on the trunk later today, if no one else does.
Comment 11 User image Ray Booysen 2005-12-15 06:21:54 PST
Great, thanks.  I haven't got checkin privs so if you can, that would be great.
Comment 12 User image Mike Schroepfer 2005-12-19 16:19:40 PST
Scott - where do you want this to land?
Comment 13 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-19 16:46:03 PST
Landed on the trunk.
mozilla/editor/ui/dialogs/content/EdInsertTOC.js; new revision: 1.3;
Comment 14 User image Bob Clary [:bc:] 2005-12-19 17:27:07 PST
This should land on the appropriate 1.8 branch so that Thunderbird 1.5 can have it as well.
Comment 15 User image Scott MacGregor 2005-12-19 17:29:30 PST
it's too late for thunderbird 1.5, we have bits in hand. Will have to wait for 1.5.0.1 unless we are forced to respin.
Comment 16 User image Scott MacGregor 2005-12-21 10:41:02 PST
Comment on attachment 205731 [details] [diff] [review]
Patch removes an extra }

schrep delegates this to me. We'll want this for tbird 1.5.0.1 so approving for that branch.
Comment 17 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-21 19:00:13 PST
Checked in on the MOZILLA_1_8_0_BRANCH.
mozilla/editor/ui/dialogs/content/EdInsertTOC.js; new revision: 1.2.36.1;
Comment 18 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-21 19:04:38 PST
Comment on attachment 205731 [details] [diff] [review]
Patch removes an extra }

I guess this should land on the 1.8 branch as well?
Comment 19 User image Scott MacGregor 2005-12-21 19:05:40 PST
Comment on attachment 205731 [details] [diff] [review]
Patch removes an extra }

yes it should.
Comment 20 User image :Gavin Sharp [email: gavin@gavinsharp.com] 2005-12-21 19:12:13 PST
Landed on the MOZILLA_1_8_BRANCH as well. mozilla/editor/ui/dialogs/content/EdInsertTOC.js; new revision: 1.2.28.1;

Note You need to log in before you can comment on or make changes to this bug.