Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Fix query filtering and keyword searching - does not work for multiple OR'ed queries

RESOLVED WONTFIX

Status

()

Toolkit
Places
P4
normal
RESOLVED WONTFIX
12 years ago
5 years ago

People

(Reporter: Brett Wilson, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
 
(Reporter)

Updated

12 years ago
Priority: -- → P2
(Reporter)

Updated

12 years ago
Priority: P2 → P1
Brett, can you put a comment in here explaining what this means, so I can track the priority and progress appropriately?
(Reporter)

Comment 2

12 years ago
Keyword searchingonly works if you have one query object (everything is ANDed together). Trying to do keyword matching with multiple query objects (OR) won't work correctly.
Target Milestone: --- → Firefox 2 alpha2
Summary: Fix query filtering and keyword searching → Fix query filtering and keyword searching - does not work for multiple OR'ed queries
(Reporter)

Comment 3

12 years ago
I'm pushing this back to B1 because it's not a dogfood issue; basic functionality works and few people will ever notice.
Priority: P1 → P3
Target Milestone: Firefox 2 alpha2 → Firefox 2 beta1
(Reporter)

Updated

11 years ago
Target Milestone: Firefox 2 beta1 → Firefox 3 alpha2
(Reporter)

Updated

11 years ago
Assignee: brettw → nobody
Target Milestone: Firefox 3 alpha2 → Firefox 3 beta1
Target Milestone: Firefox 3 M7 → Firefox 3 M8
Target Milestone: Firefox 3 M8 → Firefox 3 M9
Target Milestone: Firefox 3 M9 → Firefox 3 M10
Target Milestone: Firefox 3 M10 → Firefox 3 M11

Updated

10 years ago
Duplicate of this bug: 409567
Target Milestone: Firefox 3 beta3 → ---
good first bug if you ever want to get your hands in the Places query infrastructure.
Component: Places → Places
Priority: P3 → P4
Product: Firefox → Toolkit
QA Contact: places → places
Whiteboard: [good first bug]

Updated

5 years ago
Whiteboard: [good first bug]
considered status of this bug and the fact nobody reported it in years, I think it's really unimportant.
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.