If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Appears impossible to focus designMode compose box on netscape.com (Netscape ISP email)

VERIFIED FIXED

Status

()

Firefox
General
--
major
VERIFIED FIXED
12 years ago
12 years ago

People

(Reporter: Marshall P. Oliphant, Unassigned)

Tracking

({regression})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7.12) Gecko/20050915 Firefox/1.0.7

Whenever I go to my Netscape ISP (netscape.com) Email service, I can still reply to Emails from others, but can no longer compose NEW Emails (under "Compose")!  This problem only happens with Build 1.5, and does NOT happen with Build 1.07 (which I have currently gone back to because of this).  Under "Compose", 1.5 still allows me to write-in the address and heading, but will NOT allow me to move a cursor into the message block in order to begin an Email.  I am unable to move a cursor into the message area with either a mouse OR the keyboard!  I switched back and forth from 1.07 to 1.5 several times to test this, and 1.5 continually blocked me from composing a message, whereas 1.07 had no problems!  

Reproducible: Always

Steps to Reproduce:
1. Sign into netscape.com Email.
2. Click "Compose".
3. Write-in sendee's Email address and subject heading (optional).
4. Attempt to move cursor into message area of Email.

Actual Results:  
I am unable to get a cursor into the message area in order to write an Email, either by mouse or keyboard.  This happens whether or not I have already written-in the sendee's address and subject heading at the top (Step #3 is therefore unnecessary in order to reproduce the problem).  

Expected Results:  
The 1.5 software should have allowed me to place a cursor into the message area so that I could begin to write an Email!

I contacted Netscape ISP Help about this problem, and they said that it was a browser malfunction and not a problem on their end.
Can you also reproduce this in Firefox's safemode or with a new profile?
http://kb.mozillazine.org/Safe_Mode_(Firefox)
http://kb.mozillazine.org/Profile_Manager#How_do_I_create_a_new_profile.3F
(Reporter)

Comment 2

12 years ago
I have tried 1.5 in Safe Mode, as well as creating a new Profile Folder for 1.5, but neither of these operations changed the problem!  I am STILL unable to compose Email in Netscape's ISP (netscape.com) Email program, as 1.5 will not let me move a cursor into the "Compose" text box!

Comment 3

12 years ago
Marshall, I don't have a netscape.com account so it's hard for me to test this bug.  Can you save a page where it happens, confirm that the bug happens in the saved page, and attach it to this bug?  Or attach a reduced testcase, if you know HTML and JavaScript well enough to make one?
Keywords: regression
Summary: 1.5 won't allow me to compose Netscape ISP (netscape.com) Emails! → Can't focus textarea(?) to compose netscape.com (Netscape ISP) email

Comment 4

12 years ago
Marshall told me by email that once he starts typing in the textarea, a caret appears.  I suspect that this is a dup of bug 319935 -- the testcase there is simple enough that I wouldn't be surprised if multiple sites using designMode were affected.

Since this is probably a dup of bug 319935, it's not as important to have a testcase (reduced or not) for this bug.  Of course, if the fix for bug 319935 turns out not to fix this bug, we'd need a testcase for the problem on netscape.com.
Depends on: 319935
Summary: Can't focus textarea(?) to compose netscape.com (Netscape ISP) email → Appears impossible to focus designMode compose box on netscape.com (Netscape ISP email)

Updated

12 years ago
Depends on: 306267
No longer depends on: 319935
(Reporter)

Comment 5

12 years ago
As I just noted to Jesse in an Email, there is an additional problem with Netscape ISP webmail's "Compose" in Firefox 1.5 that seems to be related to the "invisible caret" problem!  Whenever I load the "Compose" page in Firefox 1.07, the page loads instantly, all at once, ready to use.  However, when I load "Compose" in Firefox 1.5, the page loads in PIECES, with the formatting buttons, etc., slowly popping-up one at a time until the page is finally all downloaded and ready to use.  As I said, I ASSUME that this problem is related to the "invisible caret" problem.  If not, it may be an additional 1.5 "bug" in Netscape ISP webmail's "Compose" that ought to be separately reported.  Additional Note: When the caret DOES finally appear in the Netscape ISP webmail message box in Firefox 1.5, it doesn't look as it usually does (as in 1.07)--it's much THINNER in width (I don't know why)!  Hopefully, all these problems can soon be fixed, so that I can start using 1.5.  THANKS.
(Reporter)

Comment 6

12 years ago
I have just downloaded Firefox 1.5.0.1 in hopes that you had fixed this bug.  Obviously, you haven't.  Last time, I decided to just keep 1.07 so as no to have to deal with this minor but annoying problem, but this time, I am keeping 1.5.0.1 and just working around it!  The problem remains the same, however: when writing Emails using the Netscape Internet Service, when I REPLY to Emails or FORWARD Emails, the system works normally.  However, whenever I COMPOSE a new Email, NO CARET APPEARS at the start of the message area when I begin to write (the caret does appear normally when REPLYING or FORWARDING in those message areas).  I find I AM able to write in the COMPOSE writing area, as the caret WILL appear in the text just AFTER I begin to write--but for some reason, it does NOT to appear at the BEGINNING of the text message as it does in all other modes! Can't anybody please FIX this?  It's been a long time since my first report on this "bug", and it IS a bit annoying!  Thank you!
(Reporter)

Comment 7

12 years ago
Please disregard Comment #5 from me, as that problem has been resolved.  As for Comment #6, please forgive my few grammatical errors, as I was writing much too quickly (I was UPSET that the problem still exists in 1.5.0.1!).  Thanks!
MARSHALL
There is a very good chance now that this is fixed by the fix for bug 287813.
Reporter, could you perhaps retest with a trunk build dated at 2006-04-18 or later?
Depends on: 287813
(Reporter)

Comment 9

12 years ago
I don't know if the team at Bugzilla or Netscape ISP fixed this problem (Netscape ISP came out with a newly-designed Compose page a short while ago), but the "missing caret" problem has now been resolved re: Netscape ISP's Email Compose box.
Ok, marking worksforme then, possibly fixed by bug 287813.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 11

12 years ago
I don't know if the Bugzilla team or Netscape ISP, itself, fixed this problem (Netscape completely redesigned its Compose page a little while back), but the "missing caret" problem has be resolved re: Netscape ISP's Compose page.
Resolution: WORKSFORME → FIXED
I don't have access to the Netscape ISP mail system UI, but I'm verifying this based on the reporter's comments that it now works.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.