Closed Bug 320414 Opened 15 years ago Closed 15 years ago

Find bar pops up when I type an apostrophe (') while typing an email in designMode iframe

Categories

(Toolkit :: Find Toolbar, defect)

x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 311376

People

(Reporter: micrond, Unassigned)

References

()

Details

(Keywords: helpwanted)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8) Gecko/20051111 Firefox/1.5

When entering a mail on Caramail, I'm unable to type an apostrophe (') as it pops-up the search bar eventhough automatic search is disabled.

Reproducible: Always

Steps to Reproduce:
To reproduce this, you will need a web mail account on Caramail (free, in French)
1. Go to http://www.lycos.fr/
2. On left pane, login to Caramail
3. Select button "Ecrire" to write a new e-mail
4. In the message area type an apostrophe (') 

Actual Results:  
--> The apostrophe is never shown in the message. Instead, the search bar is show and cursor appears in search field.

Expected Results:  
Apostophe should be displayed in my message

No known workaround except to use IE to write e-mail...
Copy/Paste does not work neither. 
All this works fine under EI.
Disabling automatic Find doesn't disable / or '; it only keeps other keys from triggering search so you don't trigger it accidentally.  That option is not intended to be used to work around bugs -- and it is a bug if typing ' while a textarea has focus causes the Find bar to appear.

Bug 320083 is the only other report I've seen describing this kind of problem in Firefox 1.5.  It was pretty common in Firefox 1.5 betas.  Do you have extensions installed, and if so, does disabling them help?

Can you attach a problematic page and/or a reduced testcase, so I can confirm the bug without having a caramail.lycos.fr account?
Summary: Search bar pop-up even if automatic search is disabled → Find bar pops up when I type an apostrophe (') while typing an email
Blocks: findgrabs
I saved a local copy of the page tried to reproduce the bug with it and I failed, I mean the search bar didn't popup. I created you an account and send it to you directly to you e-mail.
Thanks for creating an account for me.  I tried to reproduce the bug but I wasn't able to -- both WYSIWYG editing and typing ' and / worked fine for me.  I did notice an invisible-caret problem (probably bug 306267), though, and I wonder if the problem you're hitting is related to that.

I tested with

Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051108 Firefox/1.5

and

Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Summary: Find bar pops up when I type an apostrophe (') while typing an email → Find bar pops up when I type an apostrophe (') while typing an email in designMode iframe
Btw, what Firefox extensions do you use, if any?
Installed extensions:
- ReloadEvery 1.5
- Talkback 1.5
- ImageZoom 0.2.1
- Adblock 0.5.2.039

Note also that this bug was also present with the previous version of Mozilla Firefox.
Reproduced with fresh new installation under Windows XP SP 2
This bug occurs with FireFox 1.5 final with no extensions. Effects both Gmail and Google autocomplete as well. Confirmed on both Windows XP SP 2 and Mac OS 10.4.x.

Extermly annoying!
i have the same issue. it may have something to do with typing into form elements that were originally hidden and then unhidden via a javascript trigger.
Reproduced with Deer Park Alpha 2, version firefox-1.6a1.en-US.win32 on Windows XP SP2 without any extension.
Component: Keyboard Navigation → Find Toolbar / FastFind
Keywords: helpwanted
QA Contact: keyboard.navigation → fast.find
I can reproduce this error in FireFox 1.5 in a Gmail reply text box.  It's driving me nuts.

I have found a temporary workaround for this bug (which seems to be NOT fixed).  If you go to about:config and look for the "accessibility.typeaheadfind.flashBar" Preference Name and change its value from 0 or 1 (if it is 0, change it to 1; if it is 1, change it to 0) then the feature seems to "reset" and you will be able to enter in the arbitrary characters in textboxes again.
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8)
> Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8)
> Gecko/20051111 Firefox/1.5
> 
> When entering a mail on Caramail, I'm unable to type an apostrophe (') as it
> pops-up the search bar eventhough automatic search is disabled.  It also seems to happen with hotmail as well.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> To reproduce this, you will need a web mail account on Caramail (free, in
> French)
> 1. Go to http://www.lycos.fr/
> 2. On left pane, login to Caramail
> 3. Select button "Ecrire" to write a new e-mail
> 4. In the message area type an apostrophe (') 
> 
> Actual Results:  
> --> The apostrophe is never shown in the message. Instead, the search bar is
> show and cursor appears in search field.
> 
> Expected Results:  
> Apostophe should be displayed in my message
> 
> No known workaround except to use IE to write e-mail...
> Copy/Paste does not work neither. 
> All this works fine under EI.
> 

(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8)
> Gecko/20051111 Firefox/1.5
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; fr; rv:1.8)
> Gecko/20051111 Firefox/1.5
> 
> When entering a mail on Caramail, I'm unable to type an apostrophe (') as it
> pops-up the search bar eventhough automatic search is disabled.
> 
> Reproducible: Always
> 
> Steps to Reproduce:
> To reproduce this, you will need a web mail account on Caramail (free, in
> French)
> 1. Go to http://www.lycos.fr/
> 2. On left pane, login to Caramail
> 3. Select button "Ecrire" to write a new e-mail
> 4. In the message area type an apostrophe (') 
> 
> Actual Results:  
> --> The apostrophe is never shown in the message. Instead, the search bar is
> show and cursor appears in search field.
> 
> Expected Results:  
> Apostophe should be displayed in my message
> 
> No known workaround except to use IE to write e-mail...
> Copy/Paste does not work neither. 
> All this works fine under EI.
> 

the bug also affects hotmail messages.  impossible to type anything at length!  who is going to make a patch?
This bug is driving me crazy.  

Sometimes find as you type starts working while typing in a text frame even without typing an apostrophe or forward slash.  To temporarily fix the problem, I go into Tools->Options->Advanced->General and change the state of "Begin finding when you begin typing."  But a half hour later, the bug rears its head again, and I can't type anything into a form without Firefox trying to find the text I am typing.
Same happens when typing "/"

*** This bug has been marked as a duplicate of 311376 ***
Status: UNCONFIRMED → RESOLVED
Closed: 15 years ago
Resolution: --- → DUPLICATE
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.