"Page Setup..." should be sheet, instead of window

VERIFIED WONTFIX

Status

Camino Graveyard
Printing
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: froodian (Ian Leue), Assigned: Mike Pinkerton (not reading bugmail))

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051212 Camino/1.0b1+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8) Gecko/20051212 Camino/1.0b1+

File->Page Setup... opens a window, but it should be a sheet.  Not all apps do this (Mail) but most do, and I think it makes more sense.

Reproducible: Always

Steps to Reproduce:
(Assignee)

Comment 1

12 years ago
i'd imagine this is a dupe and would require us going to the cocoa print apis over the carbon ones. non-trivial.
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Reporter)

Comment 2

12 years ago
It's mentioned in Comment #1 for Bug 177788 (which is duped to Bug 122126), but those bugs specifically deal with the Print... and Save... dialogs.

Comment 3

12 years ago
As Page Setup is an application-wide setting, rather than a window-specific setting, I think it should remain a window, and we should WONTFIX this. (Sorry, Ian.)

cl
(Reporter)

Updated

12 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.