Closed Bug 320711 Opened 16 years ago Closed 5 years ago

Message pane flashes black when moving to another message

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
All
defect
Not set
normal

Tracking

(Not tracked)

RESOLVED WORKSFORME

People

(Reporter: emaijala+moz, Unassigned)

Details

Attachments

(1 file)

Running latest Thunderbird trunk build on WinXP SP2.

The message pane often flashes black briefly when moving from a message to another. It only happens if I have scrolled the message body and if I scroll down only five lines, the five bottom-most lines flash. Reading a long thread of messages is quite annoying when many of the messages as multiple pages long. The problem disappeared briefly when I toggled the message pane using F8 but came back soon enough. Same problem with mails and news. It seems that if it happens to take a longer time to display the next message, the message pane will stay black that time.
The bug is present also in trunk and branch (1.8) builds of Thunderbird and SeaMonkey for Linux at least since Aug. 2005 (or even earlier). OS-independent.
OS: Windows XP → All
Ah, so I'm not mad, I see this with Win2k and SeaMonkey for quite a while now.
We even discussed that a while ago in the German newsgroup de.comm.software.mozilla.nightly-builds and found this regression window:

(1.8a4 was 2004-09-27)
2004-10-09 is still okay
2004-10-28 shows black flash
(1.8a5 was 2004-11-22)
Attached screenshot of the "flash", note the black scrollbar.

JFTR: There is even another, easier way to reproduce this:

 - collapse a mail or newsaccount
 - expand it
 - select a newsgroup or folder
 - *don't* select any message
 - collapse the account again
 - be fast to take screenshot :-)

Weird thing.
QA Contact: front-end
Assignee: mscott → nobody
is this happening in only 1.8 based builds?
Ilja indicates this is WFM.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.