no way to clear downloads.rdf. Should be a way to clear or remove the file entirely.

RESOLVED FIXED in Thunderbird2.0

Status

RESOLVED FIXED
13 years ago
13 years ago

People

(Reporter: eviljeff, Assigned: mscott)

Tracking

({fixed1.8.1})

Trunk
Thunderbird2.0
fixed1.8.1
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051111 Firefox/1.5
Build Identifier: Thunderbird version 1.5 Beta 2 (20051006)

Thunderbird writes to downloads.rdf every time you extract an attachment from an email, because it uses the download manager of Firefox.  Trouble is there is no gui for this in Thunderbird and thus no way to clear the list.  This isn't a problem at first or for people who only occasionally get attachments but if you're a member of mailing lists where every email contains 1 or more attachments and you get 200+ a day you can see a problem because this has to be written (and possibly parsed, i'm not sure) on every attachment.

There should either be a way of accessing and clearing this list, or, preferably, it to be removed entirely in Thunderbird.  

I even tried setting "browser.download.manager.retention" manually, because in Firefox that would auto-clear the downloads list, but it doesn't seem to work in Thunderbird.

Reproducible: Always

Steps to Reproduce:
1. extract lots of attachments from emails
2. repeat
3. 

Actual Results:  
Thunderbird becomes slower and slower the longer you use it for because of the size of downloads.rdf

Expected Results:  
Thunderbird doesn't become any slower.

Comment 1

13 years ago
confirming - we need to either prune it ourselves or give the user a UI to do so.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Updated

13 years ago
Version: unspecified → Trunk
(Assignee)

Updated

13 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird2.0
(Assignee)

Comment 2

13 years ago
this *might* be as easy as setting:

browser.download.manager.retention to a value of 1 (remove from the download manager when thunderbird exits)

in all-thunderbird.js

That's assuming that the code which uses this pref is built and used by thunderbird in toolkit's download manager. I haven't tried to verify that yet.
(Assignee)

Comment 3

13 years ago
alas, we use the download manager in xpfe which doesn't support this behavior, otherwise that pref change would have fixed it :)
(Reporter)

Comment 4

13 years ago
As the user has no way of accessing the downloads list within thunderbird would it be safe just to auto-clear it on program start or exit?  I'm assuming theres a function to clear the list that can be called.
Alternatively its trivial to delete 'downloads.rdf' in the profile folder:

var profilefolder = Components.classes["@mozilla.org/file/directory_service;1"]
                     .getService(Components.interfaces.nsIProperties)
                     .get("ProfD", Components.interfaces.nsIFile);
profilefolder.append("downloads.rdf");
if (profilefolder.exists()) profilefolder.remove(false);
(Assignee)

Updated

13 years ago
Depends on: 239136
(Assignee)

Comment 5

13 years ago
this is going to be fixed on the trunk as part of 239136. 
Flags: blocking-thunderbird2+
(Assignee)

Updated

13 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

13 years ago
this is now fixed for thunderbird 2 via 239136
Keywords: fixed1.8.1
You need to log in before you can comment on or make changes to this bug.