toolbar view items should have a toggled appearance when toggled

RESOLVED DUPLICATE of bug 189416

Status

Calendar
Sunbird Only
RESOLVED DUPLICATE of bug 189416
12 years ago
12 years ago

People

(Reporter: Martin Meyer, Assigned: Mostafa Hosseini)

Tracking

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051220 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20051220 Firefox/1.5

Right now the Day/Week/Multiweek/Month toolbar buttons' appearance change subtly when they are clicked (or when changed from the View menu) and the button is disabled, but they should have a toggled look to further emphasize the fact that that view is currently active.

Reproducible: Always

Comment 1

12 years ago
I think this is os dependent. For example on Windows the button has a clearly visible 'pressed' state.

Comment 2

12 years ago
(In reply to comment #1)
> I think this is os dependent. For example on Windows the button has a clearly
> visible 'pressed' state.
> 
Could also be theme-dependent, although I'm not sure.  This could very easily fall under bug 189416 (possible dupe?) in either case, since radio type buttons might display better.
Bug 307335 already changes the look of the selected icon to be more clearly selected. 

Comment 4

12 years ago
Martin,
which version of Sunbird or Calendar where you using when you filed this bug? Can you take a look at Sunbird 0.3a1 (available for download at http://www.mozilla.org/projects/calendar/sunbird_download.html) and tell us if that suits your needs better.
(Reporter)

Comment 5

12 years ago
Actually when I start the .3a1 release I get an XML Parsing Error, but if I use a nightly build (Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20051229 Mozilla Sunbird/0.3a1+) then the only change I see when a view is activated is that the icon on the button changes (less blue more white) and I can't click it anymore.

Bug 307335 does indeed sound like the same thing only applied to XP Luna.

Comment 6

12 years ago

*** This bug has been marked as a duplicate of 189416 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.