Closed Bug 321591 Opened 16 years ago Closed 13 years ago

16x16 throbber icon of SeaMonkey logo is ugly

Categories

(SeaMonkey :: Themes, enhancement)

enhancement
Not set
normal

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 468103

People

(Reporter: bugzilla2, Unassigned)

References

Details

Attachments

(4 files)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051226 SeaMonkey/1.0b
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20051226 SeaMonkey/1.0b

When your toolbar setting is in "Pictures only" mode, a 16x16 version of the SeaMonkey throbber is displayed. This icon looks rather ugly compared to the 32x32 version which looks quite nice. 

I have attempted to clean up the icon, both the throbber16-single.gif and throbber16-anim.gif, to make it look nicer. Please view the attached files. 



Reproducible: Always

Steps to Reproduce:
1. Start Mozilla
2. Put toolbar setting into "Pictures only"
3. Cringe at the ugly 16x16 icon




Someone with authority please review the files and see if they are fit to be included into the SeaMonkey code. If someone can do a better job with these icons than I can, please do so. SeaMonkey should be a very polished browser. 

The files are from the following directories:

mozilla/themes/classic/communicator/brand
mozilla/themes/modern/communicator/brand
Attached image throbber16-single.gif
Attached image throbber16-anim.gif
*** This bug has been confirmed by popular vote. ***
Status: UNCONFIRMED → NEW
Ever confirmed: true
Quoted from the mozillazine forums:

"Question: Is it necessary that we have a throbber that's 16px instead of, for example, 20px or 22px? There's enough room in pictures-only mode for this size. A slightly larger throbber would look better."

Note: The toolbar button icons are 20 x 20px anyway, so there is enough height available for a slightly larger throbber.
I have created a 20x20 version (single and anim versions). Please see the attached files. 

This version fits well with "Pictures only" and even "Text only" on my system. In "Text only" mode, the URL bar is still tall enough that it makes the toolbar big enough to fit a 20x20 throbber comfortably (on my system at least). So we may not even need a 16x16 version. 

Attached image throbber20-single.gif
Attached image throbber20-anim.gif
I like the 20px size;  using 20px would be a good idea imo, though not a solution to the bug (it makes the problem less apparent, but does not eliminate it).

From what I've read, I strongly suspect that the use of indexed images for creating the throbbers has a bearing on the bug.

I believe this is unnecessary, especially for the single throbber.  Inasmuch as other throbber sets in various themes use normal RGB (not indexed) PNG images for throbber-single images with great success, I see no reason to treat the throbber-single image differently from a toolbarbutton-icon:  use a normal high-quality RGB (not indexed, not 255-colour) PNG.  It works, and the appearance is of the same quality as any toolbarbutton icon.

I also think that starting with that quality of image (as opposed to indexed) when working on the throbber-anim images, would probably result in much more acceptable animated gifs.

I'd like to emphasize that I quite like the current throbber concept: image, shape, and animation effect;  what I dislike is the execution, which has resulted in unnecessarily poor images.
In this case, the problem is not with the indexed colors, but rather the 1-bit transparency that the GIF allows. The color gradiation in the icon looks fine to me, but it is the edges of the circle (where it becomes transparent) that show problems at such a low resolution. 

Creating a PNG version of the icon would look much nicer, because it would allow alpha transparency for the edges, resulting in a much smoother circle. 

However, how would this work for the -anim version? AFAIK, there is no such thing as an animaged PNG (besides a couple of hacks, and I'm not sure these work in SeaMonkey). 

If animated PNGs do not work, then what about having the animation be in a PNG image with each frame being side-by-side in the same plane? I have seen other software products use this method, but this would involve modifying some code in SeaMonkey to make it work. 

Also, is there a higher quality (non-GIF) version of the original -anim image to work from? 
Version: unspecified → Trunk
Maybe it's just me but I can't spot a difference between our current 16px images and the ones attached here...
I haven't checked yet if the 20px works well in both our themes and all modes including full screen, but if it does, it might be a possible choice, given that the CSS works well enough for it as well... I still lean more towards the 16px version, though I can't tell you exactly why, maybe I'm too conservative to like non-usual icon sizes ;-)

And no, we only have 32px GIF images as originals, as I can't open the swf we got from the creator (and I wouldn't know how to save it in a different format if I could open it)...
http://en.wikipedia.org/wiki/SWFTools
http://www.swftools.org/

SWFTools apparently includes utilities that can extract content from SWF files.
Assignee: general → nobody
Severity: trivial → enhancement
Component: General → Themes
QA Contact: general → themes
Depends on: 468103
(In reply to comment #11)
> SWFTools apparently includes utilities that can extract content from SWF files.

Yes, it can extract parts of the swf in swf format. But I want to get that stuff out into a format I can use further, outside swf. :(
I think I can get access to a machine with MM/Adobe Flash installed. If you send me the file, I can try to convert it to something useful.
Actually, I just did a lot of work for this and bug 468103 in the last day or so and should have something to present real soon (need to test the new graphic myself first).
I'll fix this with the APNG work over in bug 468103 (patch up is for review).
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 468103
You need to log in before you can comment on or make changes to this bug.